summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 06:36:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 06:36:55 +0000
commit5f223d9b60cd001b00585e23fd78162835a78aab (patch)
treedaf7413fb31b45c782cecbcbc6f57989e9d41561 /dev-python
parentFix paths passed to python_mod_optimize() and python_mod_cleanup() (bug #2883... (diff)
downloadgentoo-2-5f223d9b60cd001b00585e23fd78162835a78aab.tar.gz
gentoo-2-5f223d9b60cd001b00585e23fd78162835a78aab.tar.bz2
gentoo-2-5f223d9b60cd001b00585e23fd78162835a78aab.zip
Version bump (bug #289376). Set SUPPORT_PYTHON_ABIS.
(Portage version: 14615-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysvn/ChangeLog8
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.1-skip_root_test.patch17
-rw-r--r--dev-python/pysvn/pysvn-1.7.1.ebuild102
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index 7048c6473fb4..f9c95c7c5cd6 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.4 2009/10/08 20:26:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.5 2009/10/17 06:36:54 arfrever Exp $
+
+*pysvn-1.7.1 (17 Oct 2009)
+
+ 17 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pysvn-1.7.1.ebuild, +files/pysvn-1.7.1-skip_root_test.patch:
+ Version bump (bug #289376). Set SUPPORT_PYTHON_ABIS.
08 Oct 2009; Fabian Groffen <grobian@gentoo.org> pysvn-1.7.0.ebuild,
+files/pysvn-1.7.0-darwin-freebsd.patch:
diff --git a/dev-python/pysvn/files/pysvn-1.7.1-skip_root_test.patch b/dev-python/pysvn/files/pysvn-1.7.1-skip_root_test.patch
new file mode 100644
index 000000000000..90f0fff48f07
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.7.1-skip_root_test.patch
@@ -0,0 +1,17 @@
+--- Tests/pysvn_test_common.mak
++++ Tests/pysvn_test_common.mak
+@@ -89,8 +89,12 @@
+
+ test-06.unix.new.log: test-06.sh test-06.unix.known_good-$(KNOWN_GOOD_VERSION).log
+ -rm -rf testroot-06
+- if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then PATH=$(SVN_BIN_DIR):$(PATH) PYTHON=$(PYTHON) ./test-06.sh >test-06.unix.new.log 2>&1; fi
+- if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then $(PYTHON) benchmark_diff.py test-06.unix.known_good-$(KNOWN_GOOD_VERSION).log test-06.unix.new.log; fi
++ if [[ $${UID} -ne 0 ]]; \
++ if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then PATH=$(SVN_BIN_DIR):$(PATH) PYTHON=$(PYTHON) ./test-06.sh >test-06.unix.new.log 2>&1; fi \
++ if PYTHONPATH=../Source $(PYTHON) svn_min_version.py 1 3 0; then $(PYTHON) benchmark_diff.py test-06.unix.known_good-$(KNOWN_GOOD_VERSION).log test-06.unix.new.log; fi \
++ else \
++ echo "Skipping $@, Reason: executed as root"; \
++ fi
+
+ clean-06:
+ -rm -f test-06.unix.new.log
diff --git a/dev-python/pysvn/pysvn-1.7.1.ebuild b/dev-python/pysvn/pysvn-1.7.1.ebuild
new file mode 100644
index 000000000000..0b88a762b2a5
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.1.ebuild,v 1.1 2009/10/17 06:36:54 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils multilib python toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-freebsd ~ppc-macos"
+IUSE="doc examples"
+
+DEPEND="dev-util/subversion
+ >=dev-python/pycxx-5.5.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Skip test test-06 if executed as root to avoid failure.
+ epatch "${FILESDIR}/${P}-skip_root_test.patch"
+
+ epatch "${FILESDIR}/${PN}-1.7.0-darwin-freebsd.patch"
+
+ # Don't use internal copy of dev-python/pycxx.
+ rm -fr Import
+
+ python_copy_sources --no-link
+
+ preparation() {
+ cd Source
+ if has "${PYTHON_ABI}" 2.4 2.5; then
+ "$(PYTHON)" setup.py backport || die "Backport failed"
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+src_configure() {
+ configuration() {
+ cd Source
+ "$(PYTHON)" setup.py configure --apr-inc-dir="${EPREFIX}/usr/include/apr-1" --svn-root-dir="${EPREFIX}/usr" || die "Configuration failed with Python {PYTHON_ABI}"
+
+ sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "/^LDSHARED=/s:g++:$(tc-getCXX):" \
+ -i Makefile \
+ || die "sed failed in Makefile"
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ cd Source
+ emake || die "emake failed with Python ${PYTHON_ABI}"
+ }
+ python_execute_function -s building
+}
+
+src_test() {
+ testing() {
+ cd Source
+ emake test || die "test-pysvn.so failed with Python ${PYTHON_ABI}"
+ emake -C ../Tests || die "Tests failed with Python ${PYTHON_ABI}"
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ installation() {
+ cd Source/pysvn
+ exeinto "$(python_get_sitedir)/pysvn"
+ doexe _pysvn*$(get_modname) || die "doexe failed"
+ insinto "$(python_get_sitedir)/pysvn"
+ doins __init__.py || die "doins failed"
+ }
+ python_execute_function -s installation
+
+ if use doc; then
+ dohtml -r ../Docs/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc ../Examples/Client/* || die "dodoc examples failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize pysvn
+}
+
+pkg_postrm() {
+ python_mod_cleanup pysvn
+}