summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-15 19:28:20 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-15 19:28:20 +0000
commit51749808ecce12d8a7cadca5122b42b020ce38e1 (patch)
treec4e4f75eb187fefb7e144dca3d08f7cf64d40085 /dev-python
parentApply interix *vim workaround to eclass, bug 310991 (diff)
downloadgentoo-2-51749808ecce12d8a7cadca5122b42b020ce38e1.tar.gz
gentoo-2-51749808ecce12d8a7cadca5122b42b020ce38e1.tar.bz2
gentoo-2-51749808ecce12d8a7cadca5122b42b020ce38e1.zip
Moved to new Python ABI stuff, #315459
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyclimate/ChangeLog9
-rw-r--r--dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-python/pyclimate/ChangeLog b/dev-python/pyclimate/ChangeLog
index f081f76bd53e..f215162c4779 100644
--- a/dev-python/pyclimate/ChangeLog
+++ b/dev-python/pyclimate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyclimate
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/ChangeLog,v 1.16 2009/11/26 17:35:59 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/ChangeLog,v 1.17 2010/04/15 19:28:19 jlec Exp $
+
+*pyclimate-1.2.2-r1 (15 Apr 2010)
+
+ 15 Apr 2010; Justin Lecher <jlec@gentoo.org> +pyclimate-1.2.2-r1.ebuild:
+ Moved to new Python ABI stuff, #315459
26 Nov 2009; Markus Meier <maekke@gentoo.org> pyclimate-1.2.2.ebuild:
amd64 stable, bug #289682
diff --git a/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild b/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..99303beba3a8
--- /dev/null
+++ b/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclimate/pyclimate-1.2.2-r1.ebuild,v 1.1 2010/04/15 19:28:20 jlec Exp $
+
+inherit eutils distutils
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+MY_P="${P/pyclimate/PyClimate}"
+
+DESCRIPTION="Climate Data Analysis Module for Python"
+SRC_URI="http://fisica.ehu.es/jsaenz/pyclimate_files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pyclimate.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/numpy
+ >=dev-python/scientificpython-2.8
+ >=sci-libs/netcdf-3.0"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ dodoc doc/* doc/dcdflib_doc/dcdflib* || die
+
+ if use examples; then
+ insinto /usr/share/${PF}
+ doins -r examples test || die
+ fi
+}