summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-18 08:35:59 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-18 08:35:59 +0000
commit35d2fcea34520f95ff046be1f69046f81fa20946 (patch)
tree8921bdb6662d7e160b4fcfb5c4fec053a19d5aec /dev-python
parentStable for amd64 wrt bug #502614 (diff)
downloadgentoo-2-35d2fcea34520f95ff046be1f69046f81fa20946.tar.gz
gentoo-2-35d2fcea34520f95ff046be1f69046f81fa20946.tar.bz2
gentoo-2-35d2fcea34520f95ff046be1f69046f81fa20946.zip
drop py2.6 py3.2, add IUSE doc, doc build, update deps
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyzmq/ChangeLog7
-rw-r--r--dev-python/pyzmq/pyzmq-14.3.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/pyzmq/ChangeLog b/dev-python/pyzmq/ChangeLog
index 51b35b8d5d10..108dafbc8081 100644
--- a/dev-python/pyzmq/ChangeLog
+++ b/dev-python/pyzmq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyzmq
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.47 2014/05/09 04:49:11 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/ChangeLog,v 1.48 2014/06/18 08:35:59 idella4 Exp $
+
+*pyzmq-14.3.1 (18 Jun 2014)
+
+ 18 Jun 2014; Ian Delaney <idella4@gentoo.org> +pyzmq-14.3.1.ebuild:
+ drop py2.6 py3.2, add IUSE doc, doc build, update deps
*pyzmq-14.3.0 (09 May 2014)
diff --git a/dev-python/pyzmq/pyzmq-14.3.1.ebuild b/dev-python/pyzmq/pyzmq-14.3.1.ebuild
new file mode 100644
index 000000000000..8666015f0a59
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-14.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-14.3.1.ebuild,v 1.1 2014/06/18 08:35:59 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples green test"
+
+PY2_USEDEP=$(python_gen_usedep 'python2*')
+RDEPEND=">=net-libs/zeromq-2.1.9
+ dev-python/py[${PY2_USEDEP}]
+ green? ( dev-python/gevent[${PY2_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_configure_all() {
+ tc-export CC
+}
+
+python_prepare_all() {
+ sed -e s':intersphinx_mapping:#&:' -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ if python_is_python3; then
+ einfo "Skipping python3 due to lack of support by gevent"
+ else
+ nosetests -svw "${BUILD_DIR}/lib/"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}