summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-31 04:26:20 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-31 04:26:20 +0000
commit30fcc5bb8074ccdac33a106f45920a98e780a4c4 (patch)
tree39b186e98cd98fdd4c5adccfdaa82884a2d9ce80 /dev-python
parentstable on arm64 (diff)
downloadgentoo-2-30fcc5bb8074ccdac33a106f45920a98e780a4c4.tar.gz
gentoo-2-30fcc5bb8074ccdac33a106f45920a98e780a4c4.tar.bz2
gentoo-2-30fcc5bb8074ccdac33a106f45920a98e780a4c4.zip
Clean up even more PYTHON_COMPAT from old implementations, add py3.4 support, fixes bug #461276
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tagpy/ChangeLog8
-rw-r--r--dev-python/tagpy/tagpy-2013.1.ebuild7
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/tagpy/ChangeLog b/dev-python/tagpy/ChangeLog
index 8135b424c190..fb818cae4669 100644
--- a/dev-python/tagpy/ChangeLog
+++ b/dev-python/tagpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/tagpy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.55 2013/09/05 18:47:12 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.56 2015/03/31 04:26:20 idella4 Exp $
+
+ 31 Mar 2015; Ian Delaney <idella4@gentoo.org> tagpy-2013.1.ebuild:
+ Clean up even more PYTHON_COMPAT from old implementations, add py3.4 support,
+ fixes bug #461276
05 Sep 2013; Michał Górny <mgorny@gentoo.org> tagpy-2013.1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/tagpy/tagpy-2013.1.ebuild b/dev-python/tagpy/tagpy-2013.1.ebuild
index 175829f77033..2d3b4810063a 100644
--- a/dev-python/tagpy/tagpy-2013.1.ebuild
+++ b/dev-python/tagpy/tagpy-2013.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-2013.1.ebuild,v 1.2 2013/09/05 18:47:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-2013.1.ebuild,v 1.3 2015/03/31 04:26:20 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -20,6 +20,7 @@ RDEPEND=">=dev-libs/boost-1.49.0[python]
>=media-libs/taglib-1.7.2"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
+
DISTUTILS_IN_SOURCE_BUILD=1
python_configure() {