summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-10 08:23:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-10 08:23:39 +0000
commit2ef7a8d0d6b8ef12e6bca4aee03a21274fd2fa69 (patch)
treeb1a4687871905a16041a1e05dee153b486d78217 /dev-python
parentRemove unused flag from metadata (diff)
downloadgentoo-2-2ef7a8d0d6b8ef12e6bca4aee03a21274fd2fa69.tar.gz
gentoo-2-2ef7a8d0d6b8ef12e6bca4aee03a21274fd2fa69.tar.bz2
gentoo-2-2ef7a8d0d6b8ef12e6bca4aee03a21274fd2fa69.zip
old
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dbus-python/ChangeLog7
-rw-r--r--dev-python/dbus-python/dbus-python-1.0.0.ebuild82
-rw-r--r--dev-python/dbus-python/dbus-python-1.1.1.ebuild77
-rw-r--r--dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch27
4 files changed, 6 insertions, 187 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 49c6621b3676..cef34d496f54 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.124 2013/05/10 08:21:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.125 2013/05/10 08:23:38 ssuominen Exp $
+
+ 10 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ -dbus-python-1.0.0.ebuild, -dbus-python-1.1.1.ebuild,
+ -files/dbus-python-1.0.0-test-socket-tmpdir.patch:
+ old
*dbus-python-1.2.0 (10 May 2013)
diff --git a/dev-python/dbus-python/dbus-python-1.0.0.ebuild b/dev-python/dbus-python/dbus-python-1.0.0.ebuild
deleted file mode 100644
index 79f62baf5cf5..000000000000
--- a/dev-python/dbus-python/dbus-python-1.0.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.0.0.ebuild,v 1.18 2012/07/15 18:11:11 armin76 Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6 3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 *-jython 2.7-pypy-*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit eutils python
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-libs/dbus-glib-0.98
- >=sys-apps/dbus-1.4.16"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( =dev-python/epydoc-3* )
- test? (
- dev-python/pygobject:2
- dev-python/pygobject:3
- )"
-
-src_prepare() {
- # Fix tests with Python 3.1.
- sed -e 's/if sys.version_info\[:2\] >= (2, 7):/if sys.version_info[:2] == (2, 7) or sys.version_info[:2] >= (3, 2):/' -i test/test-standalone.py || die "sed failed"
-
- epatch "${FILESDIR}/${P}-test-socket-tmpdir.patch"
-
- python_clean_py-compile_files
- python_src_prepare
-}
-
-src_configure() {
- configuration() {
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-html-docs \
- $(use_enable doc api-docs)
- }
- python_execute_function -s configuration
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_src_test
-}
-
-src_install() {
- python_src_install
-
- if use doc; then
- install_documentation() {
- nonfatal dohtml -r api/*
- }
- python_execute_function -f -q -s install_documentation
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- python_clean_installation_image
-}
-
-pkg_postinst() {
- python_mod_optimize dbus
-}
-
-pkg_postrm() {
- python_mod_cleanup dbus
-}
diff --git a/dev-python/dbus-python/dbus-python-1.1.1.ebuild b/dev-python/dbus-python/dbus-python-1.1.1.ebuild
deleted file mode 100644
index f47c0b0a309a..000000000000
--- a/dev-python/dbus-python/dbus-python-1.1.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-1.1.1.ebuild,v 1.7 2012/10/14 15:00:19 armin76 Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6 3:3.2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython 2.7-pypy-*"
-PYTHON_EXPORT_PHASE_FUNCTIONS=1
-
-inherit python
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-libs/dbus-glib-0.100
- >=sys-apps/dbus-1.6"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( =dev-python/epydoc-3* )
- test? (
- dev-python/pygobject:2
- dev-python/pygobject:3
- )"
-
-src_prepare() {
- >py-compile
- python_src_prepare
-}
-
-src_configure() {
- configuration() {
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-html-docs \
- $(use_enable doc api-docs)
- }
- python_execute_function -s configuration
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_src_test
-}
-
-src_install() {
- python_src_install
-
- if use doc; then
- install_documentation() {
- nonfatal dohtml -r api/*
- }
- python_execute_function -f -q -s install_documentation
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-
- python_clean_installation_image
-}
-
-pkg_postinst() {
- python_mod_optimize dbus
-}
-
-pkg_postrm() {
- python_mod_cleanup dbus
-}
diff --git a/dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch b/dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch
deleted file mode 100644
index a1ab427cdf32..000000000000
--- a/dev-python/dbus-python/files/dbus-python-1.0.0-test-socket-tmpdir.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From c53788657c0cfbd038325e690e7097e31f5e8430 Mon Sep 17 00:00:00 2001
-From: Simon McVittie <simon.mcvittie@collabora.co.uk>
-Date: Wed, 29 Feb 2012 13:35:24 +0000
-Subject: Put sockets for the regression tests in /tmp, not ${builddir}
-
-Some automated build systems (naming no Portage) have really long build
-directories, which can cause dbus-python to hit the length limit for Unix
-sockets' names.
-
-Bug: https://bugs.freedesktop.org/show_bug.cgi?id=46747
-Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
----
-diff --git a/test/tmp-session-bus.conf.in b/test/tmp-session-bus.conf.in
-index 9d172ff..3a2c756 100644
---- a/test/tmp-session-bus.conf.in
-+++ b/test/tmp-session-bus.conf.in
-@@ -4,7 +4,7 @@
- <busconfig>
- <!-- Our well-known bus type, don't change this -->
- <type>session</type>
-- <listen>unix:tmpdir=@abs_top_builddir@/test</listen>
-+ <listen>unix:tmpdir=/tmp</listen>
-
- <servicedir>@abs_top_builddir@/test</servicedir>
-
---
-cgit v0.9.0.2-2-gbebe