summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-02-29 01:59:57 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-02-29 01:59:57 +0000
commit18353711da9c6eca0e3b141c208cb4618be5561d (patch)
tree3039cc88f9c55168d9df43258da13919dfec5f5b /dev-python
parentClosing bug #42989 by installing binaries to /usr/bin. Also discovered libs n... (diff)
downloadgentoo-2-18353711da9c6eca0e3b141c208cb4618be5561d.tar.gz
gentoo-2-18353711da9c6eca0e3b141c208cb4618be5561d.tar.bz2
gentoo-2-18353711da9c6eca0e3b141c208cb4618be5561d.zip
Version bump.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mod_python/ChangeLog7
-rw-r--r--dev-python/mod_python/files/digest-mod_python-3.1.31
-rw-r--r--dev-python/mod_python/mod_python-3.1.3.ebuild59
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index 6f48ef8ea153..fce101e373b9 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.14 2004/01/29 22:40:09 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.15 2004/02/29 01:59:57 kloeri Exp $
+
+*mod_python-3.1.3 (29 Feb 2004)
+
+ 29 Feb 2004; <kloeri@gentoo.org> mod_python-3.1.3.ebuild:
+ Version bump.
*mod_python-3.0.4-r2 (29 Jan 2004)
diff --git a/dev-python/mod_python/files/digest-mod_python-3.1.3 b/dev-python/mod_python/files/digest-mod_python-3.1.3
new file mode 100644
index 000000000000..2e72ee8ba450
--- /dev/null
+++ b/dev-python/mod_python/files/digest-mod_python-3.1.3
@@ -0,0 +1 @@
+MD5 2e1983e35edd428f308b0dfeb1c23bfe mod_python-3.1.3.tgz 293548
diff --git a/dev-python/mod_python/mod_python-3.1.3.ebuild b/dev-python/mod_python/mod_python-3.1.3.ebuild
new file mode 100644
index 000000000000..51887a05eb00
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.1.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.1.3.ebuild,v 1.1 2004/02/29 01:59:57 kloeri Exp $
+
+inherit python
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="http://www.apache.org/dist/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/python
+ >=net-www/apache-2.0"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ # remove optimisations, we do that outside portage
+ sed -i -e 's:--optimize 2:--no-compile:' dist/Makefile.in
+
+ # Fix compilation when using Python-2.3
+ has_version ">=dev-lang/python-2.3" && \
+ sed -i -e 's:LONG_LONG:PY_LONG_LONG:g' \
+ "${S}/src/requestobject.c"
+}
+
+src_compile() {
+ ./configure --with-apxs=/usr/sbin/apxs2 || die
+ make OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ dodir /usr/lib/apache2-extramodules
+ make install DESTDIR=${D} LIBEXECDIR=/usr/lib/apache2-extramodules || die
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/16_mod_python.conf
+ dodoc ${FILESDIR}/16_mod_python.conf README NEWS CREDITS COPYRIGHT
+ dohtml doc-html/*
+ insinto /usr/share/doc/${PF}/html/icons
+ doins doc-html/icons/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/mod_python
+
+ einfo "To have Apache run python programs, please do the following:"
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PYTHON\""
+ einfo "That will setup Apache to load python when it starts."
+ einfo
+ einfo "If you're new to mod_python there's a manual and tutorial"
+ einfo "installed in /usr/share/doc/${PF}/html/index.html."
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}