summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-05-29 03:42:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-05-29 03:42:41 +0000
commit6bb5b0dcdbcb9d6e2aa0ccdfb4f289e633c80d40 (patch)
treeb98ea83f69b3a8f7da41b64b89e05a528cc07a85 /dev-python/wsgiintercept
parentSwitch default to moarvm (diff)
downloadgentoo-2-6bb5b0dcdbcb9d6e2aa0ccdfb4f289e633c80d40.tar.gz
gentoo-2-6bb5b0dcdbcb9d6e2aa0ccdfb4f289e633c80d40.tar.bz2
gentoo-2-6bb5b0dcdbcb9d6e2aa0ccdfb4f289e633c80d40.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog9
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index af8b335b4594..19cdaeb0d2ce 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiintercept
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.15 2015/04/07 14:20:55 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.16 2015/05/29 03:42:41 patrick Exp $
+
+*wsgiintercept-0.10.0 (29 May 2015)
+
+ 29 May 2015; Patrick Lauer <patrick@gentoo.org> +wsgiintercept-0.10.0.ebuild:
+ Bump
*wsgiintercept-0.9.1 (15 Dec 2014)
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild
new file mode 100644
index 000000000000..81b1c18a31a3
--- /dev/null
+++ b/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.10.0.ebuild,v 1.1 2015/05/29 03:42:41 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="wsgi_intercept"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI application in place of a real URI for testing"
+HOMEPAGE="https://github.com/cdent/python3-wsgi-intercept"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mechanize[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # .pyc files cause failure of tests
+ rm -rf test/__pycache__/ || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html//. )
+ distutils-r1_python_install_all
+}