summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-15 04:45:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-15 04:45:24 +0000
commit0d23093dff9fcdd1e1bf38043d7e006530a543cd (patch)
tree0b3f1443a2a045f21c2e2df3496986fbadcde7e3 /dev-python/wsgiintercept
parentbump (diff)
downloadgentoo-2-0d23093dff9fcdd1e1bf38043d7e006530a543cd.tar.gz
gentoo-2-0d23093dff9fcdd1e1bf38043d7e006530a543cd.tar.bz2
gentoo-2-0d23093dff9fcdd1e1bf38043d7e006530a543cd.zip
bump; add IUSE doc, doc build, update test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/wsgiintercept')
-rw-r--r--dev-python/wsgiintercept/ChangeLog7
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.8.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index 5c01b4364e46..2dadcbf405ab 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiintercept
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.11 2014/07/24 10:56:38 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.12 2014/08/15 04:45:24 idella4 Exp $
+
+*wsgiintercept-0.8.1 (15 Aug 2014)
+
+ 15 Aug 2014; Ian Delaney <idella4@gentoo.org> +wsgiintercept-0.8.1.ebuild:
+ bump; add IUSE doc, doc build, update test phase
*wsgiintercept-0.7.0 (24 Jul 2014)
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.8.1.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.8.1.ebuild
new file mode 100644
index 000000000000..2baf9269fb26
--- /dev/null
+++ b/dev-python/wsgiintercept/wsgiintercept-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.8.1.ebuild,v 1.1 2014/08/15 04:45:24 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="wsgi_intercept"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="WSGI application in place of a real URI for testing"
+HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mechanize[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # .pyc files cause failure of tests
+ rm -rf test/__pycache__/ || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html//. )
+ distutils-r1_python_install_all
+}