summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-01-30 13:31:16 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-01-30 13:31:16 +0000
commit15699cd3cece69928d4d616abebca87ca31866ad (patch)
tree5072ba8e16ac358081b1ca3ecc2bc6e470bf979a /dev-python/werkzeug
parentversion bump, by hfk22, bug #538206 (diff)
downloadgentoo-2-15699cd3cece69928d4d616abebca87ca31866ad.tar.gz
gentoo-2-15699cd3cece69928d4d616abebca87ca31866ad.tar.bz2
gentoo-2-15699cd3cece69928d4d616abebca87ca31866ad.zip
Version bump werkzeug to 0.10
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/ChangeLog7
-rw-r--r--dev-python/werkzeug/werkzeug-0.10.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index c1fe03cb1b64..6d7caf80aa98 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.60 2015/01/15 07:48:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.61 2015/01/30 13:31:16 djc Exp $
+
+*werkzeug-0.10 (30 Jan 2015)
+
+ 30 Jan 2015; Dirkjan Ochtman <djc@gentoo.org> +werkzeug-0.10.ebuild:
+ Version bump werkzeug to 0.10
15 Jan 2015; Patrick Lauer <patrick@gentoo.org> werkzeug-0.9.6.ebuild:
Stabilize for x86 and amd64 #527558
diff --git a/dev-python/werkzeug/werkzeug-0.10.ebuild b/dev-python/werkzeug/werkzeug-0.10.ebuild
new file mode 100644
index 000000000000..22d1db26c917
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.10.ebuild,v 1.1 2015/01/30 13:31:16 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ http://pypi.python.org/pypi/Werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/requests[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}