summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-31 00:41:17 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-31 00:41:17 +0000
commitf503f833da3e70e57c35bc261597dc3f00876d99 (patch)
tree23147df967fcdd227f871e627997938cc2160232 /dev-python/webut
parentDrop gles2 & wayland support following up current upstream status, bug #53370... (diff)
downloadgentoo-2-f503f833da3e70e57c35bc261597dc3f00876d99.tar.gz
gentoo-2-f503f833da3e70e57c35bc261597dc3f00876d99.tar.bz2
gentoo-2-f503f833da3e70e57c35bc261597dc3f00876d99.zip
revbump; conversion -> distutils-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/webut')
-rw-r--r--dev-python/webut/ChangeLog8
-rw-r--r--dev-python/webut/webut-0.1.0.2-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/webut/ChangeLog b/dev-python/webut/ChangeLog
index f128c9a889c3..2a2ca9f2f44d 100644
--- a/dev-python/webut/ChangeLog
+++ b/dev-python/webut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/webut
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webut/ChangeLog,v 1.14 2014/12/12 23:23:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webut/ChangeLog,v 1.15 2014/12/31 00:41:17 idella4 Exp $
+
+*webut-0.1.0.2-r1 (31 Dec 2014)
+
+ 31 Dec 2014; Ian Delaney <idella4@gentoo.org> +webut-0.1.0.2-r1.ebuild,
+ webut-0.1.0.2.ebuild:
+ revbump; conversion -> distutils-r1
12 Dec 2014; Michał Górny <mgorny@gentoo.org> webut-0.1.0.2.ebuild:
Rename net-zope/zope-interface to dev-python/zope-interface.
diff --git a/dev-python/webut/webut-0.1.0.2-r1.ebuild b/dev-python/webut/webut-0.1.0.2-r1.ebuild
new file mode 100644
index 000000000000..4416d6a0329d
--- /dev/null
+++ b/dev-python/webut/webut-0.1.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webut/webut-0.1.0.2-r1.ebuild,v 1.1 2014/12/31 00:41:17 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+MY_P=${PN}_$(replace_version_separator 2 '-')
+
+DESCRIPTION="Miscellaneous utilities for nevow and twisted.web programming"
+HOMEPAGE="http://www.inoi.fi/open/trac/webut"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/nevow-0.9.18[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}