summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-09-30 04:21:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-09-30 04:21:52 +0000
commit9e32798353651c4e29483e3b5159d973b0d29de5 (patch)
treeb5dac5070beac80aa80845812b9c04f0a8222c03 /dev-python/weasyprint
parentBump (diff)
downloadgentoo-2-9e32798353651c4e29483e3b5159d973b0d29de5.tar.gz
gentoo-2-9e32798353651c4e29483e3b5159d973b0d29de5.tar.bz2
gentoo-2-9e32798353651c4e29483e3b5159d973b0d29de5.zip
Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/ChangeLog7
-rw-r--r--dev-python/weasyprint/weasyprint-0.23.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/weasyprint/ChangeLog b/dev-python/weasyprint/ChangeLog
index 92cc950b4346..5408e14a2ea0 100644
--- a/dev-python/weasyprint/ChangeLog
+++ b/dev-python/weasyprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/weasyprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.10 2014/07/03 17:19:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/ChangeLog,v 1.11 2014/09/30 04:21:52 patrick Exp $
+
+*weasyprint-0.23 (30 Sep 2014)
+
+ 30 Sep 2014; Patrick Lauer <patrick@gentoo.org> +weasyprint-0.23.ebuild:
+ Bump
03 Jul 2014; Ian Delaney <idella4@gentoo.org> weasyprint-0.22.ebuild:
add py3.4, update deps, test phase
diff --git a/dev-python/weasyprint/weasyprint-0.23.ebuild b/dev-python/weasyprint/weasyprint-0.23.ebuild
new file mode 100644
index 000000000000..ca7be51eb377
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.23.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/weasyprint/weasyprint-0.23.ebuild,v 1.1 2014/09/30 04:21:52 patrick Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+RDEPEND="x11-libs/pango:0/0
+ >=media-gfx/cairosvg-1.0.7[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/cairocffi-0.5[${PYTHON_USEDEP}]
+ ~dev-python/tinycss-0.3[${PYTHON_USEDEP}]
+ >=dev-python/cssselect-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]"
+# x11-libs/gdk-pixbuf # optional dep
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}