summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-05 17:37:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-05 17:37:14 +0000
commite58be917153505559dd49fc86825527ca7692de2 (patch)
treea433cb00e96abd95908597250b45e7ceea839980 /dev-python/visual
parentold (diff)
downloadgentoo-2-e58be917153505559dd49fc86825527ca7692de2.tar.gz
gentoo-2-e58be917153505559dd49fc86825527ca7692de2.tar.bz2
gentoo-2-e58be917153505559dd49fc86825527ca7692de2.zip
Tentative bump. Dropped ppc with xarthisius blessing
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog9
-rw-r--r--dev-python/visual/visual-5.72.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index 6939351ce275..b42f44776ac6 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/visual
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.48 2011/01/15 18:21:07 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.49 2012/01/05 17:37:14 bicatali Exp $
+
+*visual-5.72 (05 Jan 2012)
+
+ 05 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +visual-5.72.ebuild:
+ Tentative bump. Dropped ppc with xarthisius blessing
15 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-visual-5.3.2.ebuild:
diff --git a/dev-python/visual/visual-5.72.ebuild b/dev-python/visual/visual-5.72.ebuild
new file mode 100644
index 000000000000..e6acf8772668
--- /dev/null
+++ b/dev-python/visual/visual-5.72.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.72.ebuild,v 1.1 2012/01/05 17:37:14 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit flag-o-matic python versionator
+
+MY_P="${PN}-$(delete_version_separator 2)_release"
+
+DESCRIPTION="Real-time 3D graphics library for Python"
+HOMEPAGE="http://www.vpython.org/"
+SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
+
+IUSE="doc examples"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="visual"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-cpp/libglademm
+ >=dev-cpp/gtkglextmm-1.2
+ dev-python/numpy
+ dev-python/polygon
+ dev-python/ttfquery"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # redundant file
+ rm src/gtk2/random_device.cpp || die
+ sed -i \
+ -e 's/random_device.lo//g' \
+ src/Makefile.in src/gtk2/makefile || die
+ # verbose build
+ sed -i -e 's/2\?>> \?\$(LOGFILE).*//' src/Makefile.in || die
+
+ echo "#!/bin/bash" > py-compile
+ python_src_prepare
+}
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ # hack to specify the include and lib directory for boost
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
+ python_src_configure \
+ --with-html-dir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --with-example-dir="${EPREFIX}/usr/share/doc/${PF}/examples" \
+ $(use_enable doc docs) \
+ $(use_enable examples)
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+ dodoc authors.txt HACKING.txt NEWS.txt || die "dodoc failed"
+ # Don't install useless vpython script.
+ rm -fr "${ED}usr/bin"
+}
+
+pkg_postinst() {
+ python_mod_optimize vis visual
+}
+
+pkg_postrm() {
+ python_mod_cleanup vis visual
+}