summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2002-12-05 13:08:40 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2002-12-05 13:08:40 +0000
commitfbe242d1642a24aae4414d4442063150ba855cc3 (patch)
treeb790749afed829ecb2e1378504a3d1a77775a5f0 /dev-python/twisted
parentremoved || die from econf line! (diff)
downloadgentoo-2-fbe242d1642a24aae4414d4442063150ba855cc3.tar.gz
gentoo-2-fbe242d1642a24aae4414d4442063150ba855cc3.tar.bz2
gentoo-2-fbe242d1642a24aae4414d4442063150ba855cc3.zip
Added IUSE and dependency for pycrypto
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.1-r11
-rw-r--r--dev-python/twisted/twisted-1.0.1-r1.ebuild33
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index a389217bf9f8..c64f1afd5b3b 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.6 2002/11/28 23:42:30 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.7 2002/12/05 13:08:40 lordvan Exp $
+*twisted-1.0.1-r1 (05 Dec 2002) Thomas Raschbacher <lordvan@gentoo.org>
+ Added dep for dev-python/pycrypto
+ Added IUSE
+
*twisted-1.0.1 (29 Nov 2002) Bart Verwilst <verwilst@gentoo.org>
New version, with lots of bugfixes to the ebuild itself as well,
diff --git a/dev-python/twisted/files/digest-twisted-1.0.1-r1 b/dev-python/twisted/files/digest-twisted-1.0.1-r1
new file mode 100644
index 000000000000..4b11759a36bf
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.1-r1
@@ -0,0 +1 @@
+MD5 1a9cf31d2a8a92132e00cdcfc376b3f3 Twisted-1.0.1.tar.bz2 3506991
diff --git a/dev-python/twisted/twisted-1.0.1-r1.ebuild b/dev-python/twisted/twisted-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..32e576d01f5f
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.1-r1.ebuild,v 1.1 2002/12/05 13:08:40 lordvan Exp $
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python
+ >=dev-python/pycrypto-1.9_alpha4"
+RDEPEND="$DEPEND"
+KEYWORDS="x86 alpha sparc sparc64"
+IUSE=""
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
+# should be taken care of by the distutils install
+# dodoc README TODO CREDITS
+}
+