summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-04 11:40:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-04 11:40:01 +0000
commit8e274b31a976aed464e4dcba38417619e0d8bdb3 (patch)
tree0f99ea0a16c07ff218f923f61f68be060c3d3353 /dev-python/translationstring
parentBackport patch from upstream solving a crash wrt bug #530646. (diff)
downloadgentoo-2-8e274b31a976aed464e4dcba38417619e0d8bdb3.tar.gz
gentoo-2-8e274b31a976aed464e4dcba38417619e0d8bdb3.tar.bz2
gentoo-2-8e274b31a976aed464e4dcba38417619e0d8bdb3.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/translationstring')
-rw-r--r--dev-python/translationstring/ChangeLog7
-rw-r--r--dev-python/translationstring/translationstring-1.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/translationstring/ChangeLog b/dev-python/translationstring/ChangeLog
index 0a712bde7c33..695c9e80596e 100644
--- a/dev-python/translationstring/ChangeLog
+++ b/dev-python/translationstring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/translationstring
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/ChangeLog,v 1.13 2014/08/21 01:22:27 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/ChangeLog,v 1.14 2014/12/04 11:40:01 patrick Exp $
+
+*translationstring-1.3 (04 Dec 2014)
+
+ 04 Dec 2014; Patrick Lauer <patrick@gentoo.org> +translationstring-1.3.ebuild:
+ Bump
21 Aug 2014; Ian Delaney <idella4@gentoo.org> translationstring-1.1-r1.ebuild:
drop py2.6 pypy2_0 add py3.4
diff --git a/dev-python/translationstring/translationstring-1.3.ebuild b/dev-python/translationstring/translationstring-1.3.ebuild
new file mode 100644
index 000000000000..7873fd0c2908
--- /dev/null
+++ b/dev-python/translationstring/translationstring-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/translationstring/translationstring-1.3.ebuild,v 1.1 2014/12/04 11:40:01 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for i18n relied on by various Repoze packages"
+HOMEPAGE="https://github.com/Pylons/translationstring http://pypi.python.org/pypi/translationstring"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( COPYRIGHT.txt )
+
+python_test() {
+ esetup.py test || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires a
+ # theme only available from git that contains hardcoded references
+ # to files on https://static.pylonsproject.org/ (so the docs would
+ # not actually work offline). Install into a "docs" subdirectory
+ # so the reference in the README remains correct.
+ docinto docs
+ docompress -x usr/share/doc/${PF}/docs
+ dodoc docs/*.rst
+}