summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-26 08:08:17 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-26 08:08:17 +0000
commit949d0c3d73729b35e9017518dabdfdb057bf6e72 (patch)
treea4d9030e73aefbe6577b6ba9b484424f5311d798 /dev-python/thunarx-python
parentversion bump (diff)
downloadgentoo-2-949d0c3d73729b35e9017518dabdfdb057bf6e72.tar.gz
gentoo-2-949d0c3d73729b35e9017518dabdfdb057bf6e72.tar.bz2
gentoo-2-949d0c3d73729b35e9017518dabdfdb057bf6e72.zip
Version bump
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/ChangeLog8
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.3.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/thunarx-python/ChangeLog b/dev-python/thunarx-python/ChangeLog
index 57efd442bbec..86e88ab54ac0 100644
--- a/dev-python/thunarx-python/ChangeLog
+++ b/dev-python/thunarx-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/thunarx-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/thunarx-python/ChangeLog,v 1.2 2011/03/13 10:56:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/thunarx-python/ChangeLog,v 1.3 2011/03/26 08:08:17 angelos Exp $
+
+*thunarx-python-0.3.0 (26 Mar 2011)
+
+ 26 Mar 2011; Christoph Mende <angelos@gentoo.org>
+ +thunarx-python-0.3.0.ebuild:
+ Version bump
*thunarx-python-0.2.3 (13 Mar 2011)
diff --git a/dev-python/thunarx-python/thunarx-python-0.3.0.ebuild b/dev-python/thunarx-python/thunarx-python-0.3.0.ebuild
new file mode 100644
index 000000000000..3e3ad42497c5
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/thunarx-python/thunarx-python-0.3.0.ebuild,v 1.1 2011/03/26 08:08:17 angelos Exp $
+
+EAPI=3
+PYTHON_DEPEND=2
+inherit python xfconf
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="http://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=dev-python/pygobject-2.16:2
+ dev-python/pygtk:2
+ >=xfce-base/thunar-1.1.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ xfconf_src_install \
+ docsdir=/usr/share/doc/${PF} \
+ examplesdir=/usr/share/doc/${PF}/examples
+}