summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-02-28 07:06:17 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-02-28 07:06:17 +0000
commitb2a0699d0ef2eaef73eb62da0b769f5bcdfc2f8d (patch)
tree00f1fe39656f8f07049241c68f088984ab94015c /dev-python/tempest-lib
parentadding for tempest-lib (diff)
downloadgentoo-2-b2a0699d0ef2eaef73eb62da0b769f5bcdfc2f8d.tar.gz
gentoo-2-b2a0699d0ef2eaef73eb62da0b769f5bcdfc2f8d.tar.bz2
gentoo-2-b2a0699d0ef2eaef73eb62da0b769f5bcdfc2f8d.zip
adding for python-keystoneclient bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/tempest-lib')
-rw-r--r--dev-python/tempest-lib/ChangeLog9
-rw-r--r--dev-python/tempest-lib/Manifest3
-rw-r--r--dev-python/tempest-lib/metadata.xml13
-rw-r--r--dev-python/tempest-lib/tempest-lib-0.3.0.ebuild51
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/tempest-lib/ChangeLog b/dev-python/tempest-lib/ChangeLog
new file mode 100644
index 000000000000..b0cdf4fa00b9
--- /dev/null
+++ b/dev-python/tempest-lib/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/tempest-lib
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tempest-lib/ChangeLog,v 1.1 2015/02/28 07:06:17 prometheanfire Exp $
+
+*tempest-lib-0.3.0 (28 Feb 2015)
+
+ 28 Feb 2015; Matthew Thode <prometheanfire@gentoo.org> +metadata.xml,
+ +tempest-lib-0.3.0.ebuild:
+ adding for python-keystoneclient bump
diff --git a/dev-python/tempest-lib/Manifest b/dev-python/tempest-lib/Manifest
new file mode 100644
index 000000000000..b1de0939513b
--- /dev/null
+++ b/dev-python/tempest-lib/Manifest
@@ -0,0 +1,3 @@
+DIST tempest-lib-0.3.0.tar.gz 53341 SHA256 0b2fdfe904b6bea12f5572f03307623ad43256694c17a5bd92ee837d8698d3c5 SHA512 e03617bd5e19b5872e4ae1e60c0eef2dfe325646f0b9d1c518f668bd7d054866b79aed494820f6ca99ee3d0735cc807aae7942f5f343e4d6c663368197be0f2c WHIRLPOOL 5f06bbaeeeb95b4724878481ddb500e1f7eaca98110cbcd2fe768917ed986656e64fae2e78e97cb099b776dbe069ad50f5c7717927ee78a5bf54f4638e8c9eec
+EBUILD tempest-lib-0.3.0.ebuild 1855 SHA256 7ac460685a7659fd86784d8761aae847d1937e11602634b9647b7c618f1dd7b9 SHA512 970d1eebde13389f714d407db1cccfc011ae41ac445e3fcdfcaab5061a3903d6930328538899d3f7a5d910c7f22c7ba0af23e8f02ef2a73fb8972db2b1cc9439 WHIRLPOOL bd4d3f3baeb353b38071fb8c728cadb447eaac8577a2dc7f40337ba3e168f373190dad4cc9d06e97da8540e8e628769ee163b016dbadff69e1882393f8fc5fce
+MISC metadata.xml 437 SHA256 0e1fd6e78ec32d200c6c58340bcee0bff3fb68db5c9ae6c89a119ce48c1bd534 SHA512 f03b0e8cf0f4f1faaecc92d6136e765fae37ea5191a10fcf5b454823be66d88bdff3cc36c5bf460a5212b9cb94a10c19ed3cead4f5400ffb85e393fa961c7fa7 WHIRLPOOL 8a70886b61d4d070be562d24403ff4c6a7e8d8f1789b4f28f3f089f126cb0a73b20806b902d7986a001f2e3dff1b08cb50441740079c414e1602f3bc91d69cb2
diff --git a/dev-python/tempest-lib/metadata.xml b/dev-python/tempest-lib/metadata.xml
new file mode 100644
index 000000000000..c71fc983f30a
--- /dev/null
+++ b/dev-python/tempest-lib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>openstack</herd>
+<herd>python</herd>
+<maintainer>
+<email>prometheanfire@gentoo.org</email>
+<name>Matthew Thode</name>
+</maintainer>
+<longdescription lang="en">
+tempest-lib is a library of common functionality that was originally in tempest (or similar in scope to tempest)
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/tempest-lib/tempest-lib-0.3.0.ebuild b/dev-python/tempest-lib/tempest-lib-0.3.0.ebuild
new file mode 100644
index 000000000000..06fc4fd3882f
--- /dev/null
+++ b/dev-python/tempest-lib/tempest-lib-0.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tempest-lib/tempest-lib-0.3.0.ebuild,v 1.1 2015/02/28 07:06:17 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to assist in creating functional or integrated test suites for OpenStack projects."
+HOMEPAGE="http://pypi.python.org/pypi/tempest-lib https://github.com/openstack/tempest-lib"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-0.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tempest_lib/tests || die "Tests fail with ${EPYTHON}"
+}