summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-14 08:08:46 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-14 08:08:46 +0000
commitc6afbeffa7b7e14126d4078c1a616dd677fbe1f6 (patch)
tree1b13eabcf1f73f183c98e1dad83a2add7d263136 /dev-python/tagpy
parentInitial commit wrt #146737, thanks to Marco Polichetti. (diff)
downloadgentoo-2-c6afbeffa7b7e14126d4078c1a616dd677fbe1f6.tar.gz
gentoo-2-c6afbeffa7b7e14126d4078c1a616dd677fbe1f6.tar.bz2
gentoo-2-c6afbeffa7b7e14126d4078c1a616dd677fbe1f6.zip
Version bump.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/ChangeLog7
-rw-r--r--dev-python/tagpy/tagpy-0.94.5.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/tagpy/ChangeLog b/dev-python/tagpy/ChangeLog
index d6f2c8cafcb5..36c32891993f 100644
--- a/dev-python/tagpy/ChangeLog
+++ b/dev-python/tagpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tagpy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.18 2008/04/21 14:04:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.19 2008/05/14 08:08:46 hawking Exp $
+
+*tagpy-0.94.5 (14 May 2008)
+
+ 14 May 2008; Ali Polatel <hawking@gentoo.org> +tagpy-0.94.5.ebuild:
+ Version bump.
21 Apr 2008; Raúl Porcel <armin76@gentoo.org> tagpy-0.93.ebuild:
Add ~sparc
diff --git a/dev-python/tagpy/tagpy-0.94.5.ebuild b/dev-python/tagpy/tagpy-0.94.5.ebuild
new file mode 100644
index 000000000000..d5827c3bb051
--- /dev/null
+++ b/dev-python/tagpy/tagpy-0.94.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-0.94.5.ebuild,v 1.1 2008/05/14 08:08:46 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="Python bindings for media-libs/taglib"
+HOMEPAGE="http://news.tiker.net/software/tagpy/"
+SRC_URI="http://cheeseshop.python.org/packages/source/t/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/python
+ >=media-libs/taglib-1.4
+ >=dev-libs/boost-1.34.1"
+
+src_compile() {
+ ./configure \
+ --taglib-inc-dir="/usr/include/taglib" \
+ --boost-python-libname="boost_python-mt"
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+}