summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-02-25 12:21:14 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-02-25 12:21:14 +0000
commitf3e422e7ab6713d0d493ecd73a070725909c982b (patch)
tree9f41013b3f22df0182ea346b923985772991edf5 /dev-python/sure
parentPunt entire CONFIG_DMIID check which seems to be more optional than README se... (diff)
downloadgentoo-2-f3e422e7ab6713d0d493ecd73a070725909c982b.tar.gz
gentoo-2-f3e422e7ab6713d0d493ecd73a070725909c982b.tar.bz2
gentoo-2-f3e422e7ab6713d0d493ecd73a070725909c982b.zip
Enable python3_3 build as it seems to work. While at it bump to latest version that is available.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-python/sure')
-rw-r--r--dev-python/sure/ChangeLog11
-rw-r--r--dev-python/sure/sure-1.2.3.ebuild6
-rw-r--r--dev-python/sure/sure-1.2.5.ebuild20
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-python/sure/ChangeLog b/dev-python/sure/ChangeLog
index c19985c63dc3..51bd8dc867e1 100644
--- a/dev-python/sure/ChangeLog
+++ b/dev-python/sure/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sure
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sure/ChangeLog,v 1.1 2013/12/02 01:04:19 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sure/ChangeLog,v 1.2 2014/02/25 12:21:14 scarabeus Exp $
+
+*sure-1.2.5 (25 Feb 2014)
+
+ 25 Feb 2014; Tomáš Chvátal <scarabeus@gentoo.org> +sure-1.2.5.ebuild,
+ sure-1.2.3.ebuild:
+ Enable python3_3 build as it seems to work. While at it bump to latest version
+ that is available.
*sure-1.2.3 (02 Dec 2013)
diff --git a/dev-python/sure/sure-1.2.3.ebuild b/dev-python/sure/sure-1.2.3.ebuild
index d5fa2a6dbe86..e87cac76c558 100644
--- a/dev-python/sure/sure-1.2.3.ebuild
+++ b/dev-python/sure/sure-1.2.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sure/sure-1.2.3.ebuild,v 1.1 2013/12/02 01:04:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sure/sure-1.2.3.ebuild,v 1.2 2014/02/25 12:21:14 scarabeus Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy2_0 )
inherit distutils-r1
diff --git a/dev-python/sure/sure-1.2.5.ebuild b/dev-python/sure/sure-1.2.5.ebuild
new file mode 100644
index 000000000000..44da62e08b60
--- /dev/null
+++ b/dev-python/sure/sure-1.2.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sure/sure-1.2.5.ebuild,v 1.1 2014/02/25 12:21:14 scarabeus Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A utility belt for automated testing in python for python"
+HOMEPAGE="http://github.com/gabrielfalcao/sure"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"