summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-05 23:22:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-05 23:22:34 +0000
commit83b90849720445712ec74f2db09bf7a00099d785 (patch)
tree213b507f6d3c5ebaf64ee292831d19a15cfe7e6a /dev-python/stsci-sphinxext
parentInitial import (diff)
downloadgentoo-2-83b90849720445712ec74f2db09bf7a00099d785.tar.gz
gentoo-2-83b90849720445712ec74f2db09bf7a00099d785.tar.bz2
gentoo-2-83b90849720445712ec74f2db09bf7a00099d785.zip
Initial import
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python/stsci-sphinxext')
-rw-r--r--dev-python/stsci-sphinxext/ChangeLog9
-rw-r--r--dev-python/stsci-sphinxext/Manifest3
-rw-r--r--dev-python/stsci-sphinxext/metadata.xml12
-rw-r--r--dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild28
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/stsci-sphinxext/ChangeLog b/dev-python/stsci-sphinxext/ChangeLog
new file mode 100644
index 000000000000..02c53c722e86
--- /dev/null
+++ b/dev-python/stsci-sphinxext/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/stsci-sphinxext
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stsci-sphinxext/ChangeLog,v 1.1 2014/02/05 23:22:34 bicatali Exp $
+
+*stsci-sphinxext-1.2.1 (05 Feb 2014)
+
+ 05 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +stsci-sphinxext-1.2.1.ebuild:
+ Initial import
diff --git a/dev-python/stsci-sphinxext/Manifest b/dev-python/stsci-sphinxext/Manifest
new file mode 100644
index 000000000000..9234012f36d5
--- /dev/null
+++ b/dev-python/stsci-sphinxext/Manifest
@@ -0,0 +1,3 @@
+DIST stsci.sphinxext-1.2.1.tar.gz 75591 SHA256 17ae92d3ee683b0ac11a0f9a8b3862207aa7790f188147dd0de6a99721776f5a SHA512 98860d6748a6be00a853b12adb283ec138c8111d7c990c5ae7f493089eb5974943aa9fb101ec8b4f280b77c49d07ce6d44c50384477d57710ded0f3382155943 WHIRLPOOL 7a44b4097e1adb88cd8bbc7c900f42702eb8cc9f100239cbdc902ec0be667085bf639c7bd37ca633e33a873edd570fd3f8b624134dd68213d49173de2e701f9d
+EBUILD stsci-sphinxext-1.2.1.ebuild 844 SHA256 c483be6111e2102a5be17ef52b37a9a8dfb55ab03d18956228405f4161ec1c48 SHA512 f177819d4c32a43753741888a17faa5bc3ec9ce50531b5f51634f5953c650f33f1861a49aaeb2fda8d12d6859db20f145035b38ad939345c9ba2009cba579fb9 WHIRLPOOL 59969ed80d1932225484312eb3812de55e79cdb9f8d53e74917b6d0c429fd0eeee8af66ec9e75ba1de5794d137b36b1bd95146d80a9d3236180759160cb958cb
+MISC metadata.xml 382 SHA256 250b4712d2e776844af3c5d2b7094b84dfa7d36a609624acc4eb031dd971569b SHA512 be1b2e52f36bc62fbdee46afc0407fb758381081878ab9ba890210be62e084532896937d6e2c0f3afa0c62e1466c2515244fbb7120aa6b43b5fddb130d4e8ef3 WHIRLPOOL e5c113becedd9be0ca2a7ca8dd0aca99490610381ee769d3f61d9563301e77bb1482613053adee75de26c8d4962dfc9951f8522c1787c22953d6c7f07380330f
diff --git a/dev-python/stsci-sphinxext/metadata.xml b/dev-python/stsci-sphinxext/metadata.xml
new file mode 100644
index 000000000000..fcf407b8d4a2
--- /dev/null
+++ b/dev-python/stsci-sphinxext/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+ This project contains extensions to Sphinx to build documentation
+ from Space Telescope Science Institute.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">stsci.sphinxext</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild b/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
new file mode 100644
index 000000000000..dd7617dfb56e
--- /dev/null
+++ b/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stsci-sphinxext/stsci-sphinxext-1.2.1.ebuild,v 1.1 2014/02/05 23:22:34 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Tools and templates to customize Sphinx for STScI projects"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpydoc[python_targets_python2_6?,python_targets_python2_7?]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"