summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-19 16:04:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-19 16:04:30 +0000
commit9c5a881b2f4ecfa148b8237ff3488b68e6a85870 (patch)
treedf72adb674272de18b07a408535f982335e91ddd /dev-python/stsci-distutils
parentVersion bump (diff)
downloadgentoo-2-9c5a881b2f4ecfa148b8237ff3488b68e6a85870.tar.gz
gentoo-2-9c5a881b2f4ecfa148b8237ff3488b68e6a85870.tar.bz2
gentoo-2-9c5a881b2f4ecfa148b8237ff3488b68e6a85870.zip
Version bump
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/stsci-distutils')
-rw-r--r--dev-python/stsci-distutils/ChangeLog9
-rw-r--r--dev-python/stsci-distutils/metadata.xml22
-rw-r--r--dev-python/stsci-distutils/stsci-distutils-0.3.1.ebuild27
3 files changed, 46 insertions, 12 deletions
diff --git a/dev-python/stsci-distutils/ChangeLog b/dev-python/stsci-distutils/ChangeLog
index 31b611fd55ff..d3cd15e02d76 100644
--- a/dev-python/stsci-distutils/ChangeLog
+++ b/dev-python/stsci-distutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/stsci-distutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stsci-distutils/ChangeLog,v 1.7 2012/06/26 23:56:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stsci-distutils/ChangeLog,v 1.8 2012/07/19 16:04:30 bicatali Exp $
+
+*stsci-distutils-0.3.1 (19 Jul 2012)
+
+ 19 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +stsci-distutils-0.3.1.ebuild, metadata.xml:
+ Version bump
26 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> stsci-distutils-0.3.ebuild:
keyword ~amd64-linux ~x86-linux
@@ -32,4 +38,3 @@
04 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +metadata.xml,
+stsci-distutils-0.2.2.ebuild:
Initial import, ebuild written by me
-
diff --git a/dev-python/stsci-distutils/metadata.xml b/dev-python/stsci-distutils/metadata.xml
index 15ba7c2fa09f..c75ae8bcd65a 100644
--- a/dev-python/stsci-distutils/metadata.xml
+++ b/dev-python/stsci-distutils/metadata.xml
@@ -1,14 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <herd>sci-astronomy</herd>
- <longdescription>This package contains utilities used to package some of STScI's Python
- projects; specifically those projects that comprise stsci_python and Astrolib.
- It currently consists mostly of some setup_hook scripts meant for use with
- distutils2/packaging and/or d2to1, and a customized easy_install command
- meant for use with distribute.</longdescription>
- <upstream>
- <remote-id type="pypi">stsci.distutils</remote-id>
- </upstream>
+<herd>python</herd>
+<herd>sci-astronomy</herd>
+<longdescription>
+ This package contains utilities used to package some of STScI's Python
+ projects; specifically those projects that comprise stsci_python and Astrolib.
+ It currently consists mostly of some setup_hook scripts meant for use with
+ distutils2/packaging and/or d2to1, and a customized easy_install command
+ meant for use with distribute.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">stsci.distutils</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/dev-python/stsci-distutils/stsci-distutils-0.3.1.ebuild b/dev-python/stsci-distutils/stsci-distutils-0.3.1.ebuild
new file mode 100644
index 000000000000..9b846e218e93
--- /dev/null
+++ b/dev-python/stsci-distutils/stsci-distutils-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stsci-distutils/stsci-distutils-0.3.1.ebuild,v 1.1 2012/07/19 16:04:30 bicatali Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS="1"
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+inherit distutils
+
+DESCRIPTION="Utilities used to package some of STScI's Python projects"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python
+ http://pypi.python.org/pypi/stsci.distutils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/d2to1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}