summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-22 19:32:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-22 19:32:06 +0000
commitd9f7f9fb76bf10e90e78283c846c2cff3de5d93b (patch)
tree183f0400c22db2ff002487fb8d50b40feb1b87cb /dev-python/simpletal
parentClarify what we mean by the "MIT" license. (diff)
downloadgentoo-2-d9f7f9fb76bf10e90e78283c846c2cff3de5d93b.tar.gz
gentoo-2-d9f7f9fb76bf10e90e78283c846c2cff3de5d93b.tar.bz2
gentoo-2-d9f7f9fb76bf10e90e78283c846c2cff3de5d93b.zip
Version bump (4.2 is the last version supporting Python 2). Set SUPPORT_PYTHON_ABIS.
(Portage version: 14874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/simpletal')
-rw-r--r--dev-python/simpletal/ChangeLog9
-rw-r--r--dev-python/simpletal/simpletal-4.2.ebuild (renamed from dev-python/simpletal/simpletal-4.1.ebuild)32
-rw-r--r--dev-python/simpletal/simpletal-5.0.ebuild48
3 files changed, 73 insertions, 16 deletions
diff --git a/dev-python/simpletal/ChangeLog b/dev-python/simpletal/ChangeLog
index b2671a4c92b6..c12788ef2cba 100644
--- a/dev-python/simpletal/ChangeLog
+++ b/dev-python/simpletal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/simpletal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.7 2009/07/21 20:51:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.8 2009/11/22 19:32:06 arfrever Exp $
+
+*simpletal-5.0 (22 Nov 2009)
+*simpletal-4.2 (22 Nov 2009)
+
+ 22 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -simpletal-4.1.ebuild, +simpletal-4.2.ebuild, +simpletal-5.0.ebuild:
+ Version bump (4.2 is the last version supporting Python 2). Set SUPPORT_PYTHON_ABIS.
21 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
simpletal-4.1.ebuild:
diff --git a/dev-python/simpletal/simpletal-4.1.ebuild b/dev-python/simpletal/simpletal-4.2.ebuild
index 659ed956bb7b..9455a274c279 100644
--- a/dev-python/simpletal/simpletal-4.1.ebuild
+++ b/dev-python/simpletal/simpletal-4.2.ebuild
@@ -1,30 +1,41 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-4.1.ebuild,v 1.2 2009/07/21 20:51:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-4.2.ebuild,v 1.1 2009/11/22 19:32:06 arfrever Exp $
EAPI="2"
-NEED_PYTHON=2.3
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-MY_P=SimpleTAL-${PV}
+MY_PN="SimpleTAL"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates."
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ http://pypi.python.org/pypi/SimpleTAL"
SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz"
-HOMEPAGE="http://www.owlfish.com/software/simpleTAL/"
LICENSE="BSD"
-SLOT="0"
+SLOT="4"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="examples"
-RESTRICT="test"
DEPEND="dev-python/pyxml"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
S="${WORKDIR}/${MY_P}"
+src_test() {
+ sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" -i tests/TALUtilsTests/TemplateCacheTestCases.py || die "sed failed"
+
+ testing() {
+ "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
@@ -35,12 +46,3 @@ src_install() {
doins -r examples
fi
}
-
-src_test() {
- sed -i \
- -e 's/TEMP_DIR=.*/TEMP_DIR=os.curdir/' \
- tests/TALUtilsTests/TemplateCacheTestCases.py \
- || die "sed failed"
-
- "${python}" runtests.py || die "tests failed"
-}
diff --git a/dev-python/simpletal/simpletal-5.0.ebuild b/dev-python/simpletal/simpletal-5.0.ebuild
new file mode 100644
index 000000000000..741cb86e8498
--- /dev/null
+++ b/dev-python/simpletal/simpletal-5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-5.0.ebuild,v 1.1 2009/11/22 19:32:06 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="3.0"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="SimpleTAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SimpleTAL is a stand alone Python implementation of the TAL, TALES and METAL specifications used in Zope to power HTML and XML templates."
+HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ http://pypi.python.org/pypi/SimpleTAL"
+SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" -i tests/TALUtilsTests/TemplateCacheTestCases.py || die "sed failed"
+
+ testing() {
+ "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml documentation/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}