summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-01 10:07:50 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-01 10:07:50 +0000
commit54577fb4c9038cc5c3a32a1001a4a8b42b5680e3 (patch)
treec05f263ca78c4fb52b8b32bd389dafb69fe8164c /dev-python/simplejson
parentVersion bump (diff)
downloadgentoo-2-54577fb4c9038cc5c3a32a1001a4a8b42b5680e3.tar.gz
gentoo-2-54577fb4c9038cc5c3a32a1001a4a8b42b5680e3.tar.bz2
gentoo-2-54577fb4c9038cc5c3a32a1001a4a8b42b5680e3.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-3.7.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 2fb398cd6bdb..190bce04cbd7 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.150 2015/05/23 08:17:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.151 2015/06/01 10:07:50 jlec Exp $
+
+*simplejson-3.7.3 (01 Jun 2015)
+
+ 01 Jun 2015; Justin Lecher <jlec@gentoo.org> +simplejson-3.7.3.ebuild:
+ Version Bump
*simplejson-3.7.2 (23 May 2015)
diff --git a/dev-python/simplejson/simplejson-3.7.3.ebuild b/dev-python/simplejson/simplejson-3.7.3.ebuild
new file mode 100644
index 000000000000..59b6bc5236ef
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.7.3.ebuild,v 1.1 2015/06/01 10:07:50 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}