summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-18 12:57:47 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-18 12:57:47 +0000
commitb839c2058183d724f01c4a9df75813f337846a9f (patch)
tree6468197d5a10fa85d703cfa754e973c16f279cc5 /dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild
parentRevbump to add systemd unit file. Thanks to Fabio Erculiani <lxnay@gentoo.org... (diff)
downloadgentoo-2-b839c2058183d724f01c4a9df75813f337846a9f.tar.gz
gentoo-2-b839c2058183d724f01c4a9df75813f337846a9f.tar.bz2
gentoo-2-b839c2058183d724f01c4a9df75813f337846a9f.zip
revbump; migrate -> distutils-r1
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild')
-rw-r--r--dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild b/dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild
new file mode 100644
index 000000000000..a8a3680f1e46
--- /dev/null
+++ b/dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools_hg/setuptools_hg-0.4-r1.ebuild,v 1.1 2013/05/18 12:57:47 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools/distribute plugin for finding files under Mercurial version control."
+HOMEPAGE="http://pypi.python.org/pypi/setuptools_hg http://bitbucket.org/jezdez/setuptools_hg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-vcs/mercurial"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"