summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-14 07:55:51 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-14 07:55:51 +0000
commit43ad2756a9466ea3a04a08bdbf259448e81be1de (patch)
treee3551d2012f3d24020d28dde3aa53c8a17f112c7 /dev-python/selenium
parentDrop obsolete pypy mask (diff)
downloadgentoo-2-43ad2756a9466ea3a04a08bdbf259448e81be1de.tar.gz
gentoo-2-43ad2756a9466ea3a04a08bdbf259448e81be1de.tar.bz2
gentoo-2-43ad2756a9466ea3a04a08bdbf259448e81be1de.zip
Version Bump; drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/ChangeLog8
-rw-r--r--dev-python/selenium/selenium-2.26.0.ebuild24
-rw-r--r--dev-python/selenium/selenium-2.39.0.ebuild21
-rw-r--r--dev-python/selenium/selenium-2.45.0.ebuild (renamed from dev-python/selenium/selenium-2.29.0.ebuild)9
4 files changed, 13 insertions, 49 deletions
diff --git a/dev-python/selenium/ChangeLog b/dev-python/selenium/ChangeLog
index 24f3b2873fd0..b9f1f70d274f 100644
--- a/dev-python/selenium/ChangeLog
+++ b/dev-python/selenium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/selenium
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/selenium/ChangeLog,v 1.11 2015/04/08 08:04:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/selenium/ChangeLog,v 1.12 2015/04/14 07:55:51 jlec Exp $
+
+*selenium-2.45.0 (14 Apr 2015)
+
+ 14 Apr 2015; Justin Lecher <jlec@gentoo.org> +selenium-2.45.0.ebuild,
+ -selenium-2.26.0.ebuild, -selenium-2.29.0.ebuild, -selenium-2.39.0.ebuild:
+ Version Bump; drop old
08 Apr 2015; Michał Górny <mgorny@gentoo.org> selenium-2.29.0.ebuild,
selenium-2.39.0.ebuild, selenium-2.42.1.ebuild:
diff --git a/dev-python/selenium/selenium-2.26.0.ebuild b/dev-python/selenium/selenium-2.26.0.ebuild
deleted file mode 100644
index 0571761023f7..000000000000
--- a/dev-python/selenium/selenium-2.26.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/selenium/selenium-2.26.0.ebuild,v 1.2 2013/09/24 22:43:08 vapier Exp $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-#RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-inherit distutils
-
-DESCRIPTION="a Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
-HOMEPAGE="http://pypi.python.org/pypi/selenium/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc"
-LICENSE="Apache-2.0"
-SLOT="0"
-DOCS=( README.md py/README )
-
-src_install() {
- distutils_src_install
- dodoc ${DOCS[@]}
-}
diff --git a/dev-python/selenium/selenium-2.39.0.ebuild b/dev-python/selenium/selenium-2.39.0.ebuild
deleted file mode 100644
index f1355c499665..000000000000
--- a/dev-python/selenium/selenium-2.39.0.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/selenium/selenium-2.39.0.ebuild,v 1.2 2015/04/08 08:04:59 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="a Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
-HOMEPAGE="http://pypi.python.org/pypi/selenium/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-DOCS=( py/CHANGES py/README )
-DISTUTILS_IN_SOURCE_BUILD=1
-QA_PREBUILT="/usr/lib*/python*/site-packages/${PN}/webdriver/firefox/*/x_ignore_nofocus.so"
diff --git a/dev-python/selenium/selenium-2.29.0.ebuild b/dev-python/selenium/selenium-2.45.0.ebuild
index 1bff7be0d822..bb55388f113d 100644
--- a/dev-python/selenium/selenium-2.29.0.ebuild
+++ b/dev-python/selenium/selenium-2.45.0.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/selenium/selenium-2.29.0.ebuild,v 1.5 2015/04/08 08:04:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/selenium/selenium-2.45.0.ebuild,v 1.1 2015/04/14 07:55:51 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit distutils-r1
-DESCRIPTION="a Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
+DESCRIPTION="Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
HOMEPAGE="http://pypi.python.org/pypi/selenium/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -16,6 +17,8 @@ IUSE="doc"
LICENSE="Apache-2.0"
SLOT="0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
DOCS=( py/CHANGES py/README )
DISTUTILS_IN_SOURCE_BUILD=1
QA_PREBUILT="/usr/lib*/python*/site-packages/${PN}/webdriver/firefox/*/x_ignore_nofocus.so"