summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-09-10 01:36:55 +0000
committerMike Gilbert <floppym@gentoo.org>2014-09-10 01:36:55 +0000
commitc26a03fd523ce5ba71aa81d65997311dfcea1a8a (patch)
tree09d3f294f286be2d74ede02860e8310275311051 /dev-python/requests
parentAdd build-time dep on freetype for coreboot, qemu, ieee1275 and loongson. Bug... (diff)
downloadgentoo-2-c26a03fd523ce5ba71aa81d65997311dfcea1a8a.tar.gz
gentoo-2-c26a03fd523ce5ba71aa81d65997311dfcea1a8a.tar.bz2
gentoo-2-c26a03fd523ce5ba71aa81d65997311dfcea1a8a.zip
Version bump, resolves bug 522466.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-2.4.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index 72aac32c9424..cc09662a3ad2 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.71 2014/09/09 06:47:52 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.72 2014/09/10 01:36:55 floppym Exp $
+
+*requests-2.4.1 (10 Sep 2014)
+
+ 10 Sep 2014; Mike Gilbert <floppym@gentoo.org> +requests-2.4.1.ebuild:
+ Version bump, resolves bug 522466.
*requests-2.4.0 (09 Sep 2014)
diff --git a/dev-python/requests/requests-2.4.1.ebuild b/dev-python/requests/requests-2.4.1.ebuild
new file mode 100644
index 000000000000..4587b1a0ac79
--- /dev/null
+++ b/dev-python/requests/requests-2.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.4.1.ebuild,v 1.1 2014/09/10 01:36:55 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+# bundles dev-python/urllib3 snapshot
+RDEPEND="app-misc/ca-certificates
+ >=dev-python/chardet-2.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-system-chardet.patch \
+ "${FILESDIR}"/${PN}-2.4.0-system-cacerts.patch )
+
+python_prepare_all() {
+ # use system chardet
+ rm -r requests/packages/chardet || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test_requests.py || die "Tests fail with ${EPYTHON}"
+}