summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-19 09:08:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-19 09:08:07 +0000
commit2bb785aad8a70b9865e01db11c6018157a418008 (patch)
tree93f413553561c5f328dcee8c668d6e0d801a551d /dev-python/quixote
parentBump (diff)
downloadgentoo-2-2bb785aad8a70b9865e01db11c6018157a418008.tar.gz
gentoo-2-2bb785aad8a70b9865e01db11c6018157a418008.tar.bz2
gentoo-2-2bb785aad8a70b9865e01db11c6018157a418008.zip
Bump
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/quixote')
-rw-r--r--dev-python/quixote/ChangeLog7
-rw-r--r--dev-python/quixote/quixote-2.7.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/quixote/ChangeLog b/dev-python/quixote/ChangeLog
index 202b7d5b8aeb..e7583801d125 100644
--- a/dev-python/quixote/ChangeLog
+++ b/dev-python/quixote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/quixote
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/ChangeLog,v 1.34 2012/02/21 08:19:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/ChangeLog,v 1.35 2012/04/19 09:08:07 patrick Exp $
+
+*quixote-2.7 (19 Apr 2012)
+
+ 19 Apr 2012; Patrick Lauer <patrick@gentoo.org> +quixote-2.7.ebuild:
+ Bump
21 Feb 2012; Patrick Lauer <patrick@gentoo.org> quixote-2.6.ebuild:
Restricting jython
diff --git a/dev-python/quixote/quixote-2.7.ebuild b/dev-python/quixote/quixote-2.7.ebuild
new file mode 100644
index 000000000000..8c34c08b7f0f
--- /dev/null
+++ b/dev-python/quixote/quixote-2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/quixote-2.7.ebuild,v 1.1 2012/04/19 09:08:06 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils
+
+MY_P="${P/q/Q}"
+
+DESCRIPTION="Python HTML templating framework for developing web applications"
+HOMEPAGE="http://quixote.ca"
+SRC_URI="http://quixote.ca/releases/${MY_P}.tar.gz"
+
+LICENSE="CNRI-QUIXOTE-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"/${MY_P}
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="ACKS.txt CHANGES.txt doc/*.txt"
+
+src_install() {
+ distutils_src_install
+ dohtml doc/*.html || die "dohtml failed"
+}