summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-03 21:29:17 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-03 21:29:17 +0000
commitfcb188f5868ec50bb09b43ed4f486b737828c562 (patch)
tree3f128cd877e6d690e4b6cbfef44c8e91d59bd6c0 /dev-python/pyxattr
parentfix build with automake-1.12 wrt #449864 (diff)
downloadgentoo-2-fcb188f5868ec50bb09b43ed4f486b737828c562.tar.gz
gentoo-2-fcb188f5868ec50bb09b43ed4f486b737828c562.tar.bz2
gentoo-2-fcb188f5868ec50bb09b43ed4f486b737828c562.zip
Introduce a live ebuild to make testing HEAD easier.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/ChangeLog9
-rw-r--r--dev-python/pyxattr/pyxattr-9999.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-python/pyxattr/ChangeLog b/dev-python/pyxattr/ChangeLog
index 8ec551ccfeda..cd24f58a4698 100644
--- a/dev-python/pyxattr/ChangeLog
+++ b/dev-python/pyxattr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyxattr
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.42 2012/12/22 21:25:40 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.43 2013/01/03 21:29:17 mgorny Exp $
+
+*pyxattr-9999 (03 Jan 2013)
+
+ 03 Jan 2013; Michał Górny <mgorny@gentoo.org> +pyxattr-9999.ebuild:
+ Introduce a live ebuild to make testing HEAD easier.
22 Dec 2012; Zac Medico <zmedico@gentoo.org> pyxattr-0.5.1.ebuild:
Add pypy{1_9,2_0} to PYTHON_COMPAT, since they appear to work.
diff --git a/dev-python/pyxattr/pyxattr-9999.ebuild b/dev-python/pyxattr/pyxattr-9999.ebuild
new file mode 100644
index 000000000000..d1363c1ec9da
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-9999.ebuild,v 1.1 2013/01/03 21:29:17 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
+
+#if LIVE
+EGIT_REPO_URI="https://github.com/iustin/${PN}.git
+ git://github.com/iustin/${PN}.git"
+inherit git-2
+#endif
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+#endif
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}