summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-03 08:07:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-03 08:07:27 +0000
commitcd611270955698c7e03785c7847ab1d70b45702b (patch)
tree1c3dc6a8b06be48cea8b5409e197221c1d836978 /dev-python/pyx
parentVersion bump. (diff)
downloadgentoo-2-cd611270955698c7e03785c7847ab1d70b45702b.tar.gz
gentoo-2-cd611270955698c7e03785c7847ab1d70b45702b.tar.bz2
gentoo-2-cd611270955698c7e03785c7847ab1d70b45702b.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyx')
-rw-r--r--dev-python/pyx/ChangeLog7
-rw-r--r--dev-python/pyx/pyx-0.13.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index aa1cd89f825a..d7901a45cc2b 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.38 2014/03/31 21:01:35 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.39 2014/05/03 08:07:27 patrick Exp $
+
+*pyx-0.13 (03 May 2014)
+
+ 03 May 2014; Patrick Lauer <patrick@gentoo.org> +pyx-0.13.ebuild:
+ Bump
31 Mar 2014; Michał Górny <mgorny@gentoo.org> pyx-0.12.1-r1.ebuild:
Add support for the new PyPy slotting.
diff --git a/dev-python/pyx/pyx-0.13.ebuild b/dev-python/pyx/pyx-0.13.ebuild
new file mode 100644
index 000000000000..6a48d4ed7576
--- /dev/null
+++ b/dev-python/pyx/pyx-0.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.13.ebuild,v 1.1 2014/05/03 08:07:26 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS CHANGES )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ cd "${S}/faq"
+ VARTEXFONTS="${T}"/fonts make latexpdf
+ fi
+}
+
+python_install_all() {
+ use doc && dodoc faq/_build/latex/pyxfaq.pdf
+}