summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-23 15:26:55 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-23 15:26:55 +0000
commit5ab6deea43d498490d92ed21c24ac141751dde74 (patch)
tree521b1e0bcb861d2a7f240b7522c09583edf59d6f /dev-python/pywebkitgtk
parentrebuild whole migration, missing test phase added, resticted until 1 final is... (diff)
downloadgentoo-2-5ab6deea43d498490d92ed21c24ac141751dde74.tar.gz
gentoo-2-5ab6deea43d498490d92ed21c24ac141751dde74.tar.bz2
gentoo-2-5ab6deea43d498490d92ed21c24ac141751dde74.zip
Use autotools-utils for out-of-source building, bug 474360.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pywebkitgtk')
-rw-r--r--dev-python/pywebkitgtk/ChangeLog5
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild22
2 files changed, 12 insertions, 15 deletions
diff --git a/dev-python/pywebkitgtk/ChangeLog b/dev-python/pywebkitgtk/ChangeLog
index ec1137318c0d..b8b38445ef49 100644
--- a/dev-python/pywebkitgtk/ChangeLog
+++ b/dev-python/pywebkitgtk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pywebkitgtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.30 2013/06/23 15:08:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.31 2013/06/23 15:26:55 floppym Exp $
+
+ 23 Jun 2013; Mike Gilbert <floppym@gentoo.org> pywebkitgtk-1.1.8-r1.ebuild:
+ Use autotools-utils for out-of-source building, bug 474360.
23 Jun 2013; Ian Delaney <idella4@gentoo.org> pywebkitgtk-1.1.8-r1.ebuild:
rebuild whole migration, missing test phase added, resticted until 1 final
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
index 350bf3623887..7d7977be1724 100644
--- a/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
+++ b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild,v 1.2 2013/06/23 15:08:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild,v 1.3 2013/06/23 15:26:55 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python-r1
+inherit autotools-utils python-r1
DESCRIPTION="Python bindings for the WebKit GTK+ port"
HOMEPAGE="http://code.google.com/p/pywebkitgtk/"
@@ -23,23 +23,15 @@ RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
DEPEND="${RDEPEND}
virtual/pkgconfig"
-DOCS=( AUTHORS MAINTAINERS NEWS README )
RESTRICT="test"
-src_prepare() {
- python_copy_sources
-}
-
src_configure() {
- config() {
- econf --disable-static
- }
-#ECONF_SOURCE="{S}" econf --disable-static
- python_parallel_foreach_impl run_in_build_dir config
+ local myeconfargs=( --disable-static )
+ python_parallel_foreach_impl autotools-utils_src_configure
}
src_compile() {
- python_foreach_impl run_in_build_dir emake
+ python_foreach_impl autotools-utils_src_compile
}
# Need fix a dbus session issue run as root
@@ -64,5 +56,7 @@ src_test() {
}
src_install() {
- python_foreach_impl run_in_build_dir default
+ local AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+ local DOCS=( AUTHORS MAINTAINERS NEWS README )
+ python_foreach_impl autotools-utils_src_install
}