summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-03-18 23:52:40 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-03-18 23:52:40 +0000
commit6b6a78730dceebd5e741eedd1097b884ea043435 (patch)
tree0c28439bb1f5224ca943d0edd42d5068bd48560e /dev-python/pyutil
parentversion bump (diff)
downloadgentoo-2-6b6a78730dceebd5e741eedd1097b884ea043435.tar.gz
gentoo-2-6b6a78730dceebd5e741eedd1097b884ea043435.tar.bz2
gentoo-2-6b6a78730dceebd5e741eedd1097b884ea043435.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-python/pyutil')
-rw-r--r--dev-python/pyutil/ChangeLog9
-rw-r--r--dev-python/pyutil/pyutil-2.0.0.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/pyutil/ChangeLog b/dev-python/pyutil/ChangeLog
index e8ffb27264eb..eb0d071fd8ba 100644
--- a/dev-python/pyutil/ChangeLog
+++ b/dev-python/pyutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyutil
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyutil/ChangeLog,v 1.4 2013/11/24 13:48:41 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyutil/ChangeLog,v 1.5 2014/03/18 23:52:40 hasufell Exp $
+
+*pyutil-2.0.0 (18 Mar 2014)
+
+ 18 Mar 2014; Julian Ospald <hasufell@gentoo.org> +pyutil-2.0.0.ebuild:
+ version bump
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> pyutil-1.9.7.ebuild:
Stable for x86, wrt bug #491540
diff --git a/dev-python/pyutil/pyutil-2.0.0.ebuild b/dev-python/pyutil/pyutil-2.0.0.ebuild
new file mode 100644
index 000000000000..cfaaa78db64a
--- /dev/null
+++ b/dev-python/pyutil/pyutil-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyutil/pyutil-2.0.0.ebuild,v 1.1 2014/03/18 23:52:40 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities for Python programmers"
+HOMEPAGE="https://tahoe-lafs.org/trac/pyutil https://pypi.python.org/pypi/pyutil"
+SRC_URI="mirror://pypi/p/pyutil/pyutil-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${ED%/}"/usr/share/doc/${PN}
+}