summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-07-08 16:20:08 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-07-08 16:20:08 +0000
commit3829d323f8994bdf786d3e7e05a81a16695ae4b1 (patch)
tree960c2e73920e4830823bd54c1784fd5f5cdd6401 /dev-python/python-swiftclient
parentadd support for reading Process Accounting files (EXPERIMENTAL, Linux only) (... (diff)
downloadgentoo-2-3829d323f8994bdf786d3e7e05a81a16695ae4b1.tar.gz
gentoo-2-3829d323f8994bdf786d3e7e05a81a16695ae4b1.tar.bz2
gentoo-2-3829d323f8994bdf786d3e7e05a81a16695ae4b1.zip
removing bad versions for bug 491368 CVE-2013-6396 and bumping to 2.1.0
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/ChangeLog8
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-2.1.0.ebuild (renamed from dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild)26
2 files changed, 20 insertions, 14 deletions
diff --git a/dev-python/python-swiftclient/ChangeLog b/dev-python/python-swiftclient/ChangeLog
index e18c7ec82feb..4771f41c1471 100644
--- a/dev-python/python-swiftclient/ChangeLog
+++ b/dev-python/python-swiftclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-swiftclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.14 2014/04/27 05:34:59 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.15 2014/07/08 16:20:08 prometheanfire Exp $
+
+*python-swiftclient-2.1.0 (08 Jul 2014)
+
+ 08 Jul 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-swiftclient-2.1.0.ebuild, -python-swiftclient-1.9.0.ebuild:
+ removing bad versions for bug 491368 CVE-2013-6396 and bumping to 2.1.0
27 Apr 2014; Matthew Thode <prometheanfire@gentoo.org>
-python-swiftclient-1.3.0.ebuild, -python-swiftclient-1.5.0.ebuild,
diff --git a/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-2.1.0.ebuild
index 8b5891eb928e..3e2e7954aa87 100644
--- a/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild
+++ b/dev-python/python-swiftclient/python-swiftclient-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-1.9.0.ebuild,v 1.1 2014/03/30 05:06:16 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-2.1.0.ebuild,v 1.1 2014/07/08 16:20:08 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -13,26 +13,26 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
- test? ( ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
>=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
<dev-python/hacking-0.9[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )
- )"
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}] ) )"
RDEPEND=">=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
- >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
- <dev-python/d2to1-0.3[${PYTHON_USEDEP}]"
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
python_prepare() {
sed -i '/discover/d' "${S}/test-requirements.txt" || die "sed failed"