summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-02-12 21:54:52 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-02-12 21:54:52 +0000
commit76f6794e53546a3c25e6c65b7f8f316027c898f9 (patch)
tree00f4c372977962d57f7a6a7eaa02fcc3f66f4a4e /dev-python/python-gflags
parentVersion bump. (diff)
downloadgentoo-2-76f6794e53546a3c25e6c65b7f8f316027c898f9.tar.gz
gentoo-2-76f6794e53546a3c25e6c65b7f8f316027c898f9.tar.bz2
gentoo-2-76f6794e53546a3c25e6c65b7f8f316027c898f9.zip
Version bump.
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-gflags')
-rw-r--r--dev-python/python-gflags/ChangeLog10
-rw-r--r--dev-python/python-gflags/python-gflags-1.5.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/python-gflags/ChangeLog b/dev-python/python-gflags/ChangeLog
index dc76efd98c44..5aafebd01290 100644
--- a/dev-python/python-gflags/ChangeLog
+++ b/dev-python/python-gflags/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-gflags
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gflags/ChangeLog,v 1.2 2010/11/14 21:30:04 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gflags/ChangeLog,v 1.3 2011/02/12 21:54:52 nelchael Exp $
+
+*python-gflags-1.5 (12 Feb 2011)
+
+ 12 Feb 2011; Krzysztof Pawlik <nelchael@gentoo.org>
+ +python-gflags-1.5.ebuild:
+ Version bump.
14 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-gflags-1.4.ebuild:
diff --git a/dev-python/python-gflags/python-gflags-1.5.ebuild b/dev-python/python-gflags/python-gflags-1.5.ebuild
new file mode 100644
index 000000000000..ecae4ed8dadb
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gflags/python-gflags-1.5.ebuild,v 1.1 2011/02/12 21:54:52 nelchael Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Google's Python argument parsing library."
+HOMEPAGE="http://code.google.com/p/python-gflags/"
+SRC_URI="http://python-gflags.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_MODNAME="gflags.py"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e 's/data_files=\[("bin", \["gflags2man.py"\])\]/scripts=\["gflags2man.py"\]/' -i setup.py
+}