summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-21 13:41:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-21 13:41:14 +0000
commit0c06521a6a3be3c94871f0513147e7cd7f589f87 (patch)
tree54ebdd7c79a477f4448d12fcd5f29d0933f1b720 /dev-python/python-geoclue
parentx86 stable wrt bug #481522 (diff)
downloadgentoo-2-0c06521a6a3be3c94871f0513147e7cd7f589f87.tar.gz
gentoo-2-0c06521a6a3be3c94871f0513147e7cd7f589f87.tar.bz2
gentoo-2-0c06521a6a3be3c94871f0513147e7cd7f589f87.zip
dev-python/python-geoclue: Bump to new python eclasses
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/python-geoclue')
-rw-r--r--dev-python/python-geoclue/ChangeLog8
-rw-r--r--dev-python/python-geoclue/metadata.xml8
-rw-r--r--dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild33
3 files changed, 44 insertions, 5 deletions
diff --git a/dev-python/python-geoclue/ChangeLog b/dev-python/python-geoclue/ChangeLog
index 0fe4748bd519..bff49a2f799d 100644
--- a/dev-python/python-geoclue/ChangeLog
+++ b/dev-python/python-geoclue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-geoclue
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/ChangeLog,v 1.10 2013/02/02 22:30:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/ChangeLog,v 1.11 2013/08/21 13:41:14 jlec Exp $
+
+*python-geoclue-0.1.0-r1 (21 Aug 2013)
+
+ 21 Aug 2013; Justin Lecher <jlec@gentoo.org> +python-geoclue-0.1.0-r1.ebuild,
+ metadata.xml:
+ Bump to new python eclasses
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> python-geoclue-0.1.0.ebuild:
Add ~arm, wrt bug #449220
diff --git a/dev-python/python-geoclue/metadata.xml b/dev-python/python-geoclue/metadata.xml
index fc861fa44740..6c90e346eb69 100644
--- a/dev-python/python-geoclue/metadata.xml
+++ b/dev-python/python-geoclue/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild b/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..ffa69a336d5a
--- /dev/null
+++ b/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/python-geoclue-0.1.0-r1.ebuild,v 1.1 2013/08/21 13:41:14 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Geoclue python module"
+HOMEPAGE="http://live.gnome.org/gtg/soc/python_geoclue/"
+SRC_URI="http://www.paulocabido.com/soc/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="test"
+
+RDEPEND="
+ app-misc/geoclue
+ dev-python/dbus-python[${PYTHON_USEDEP}]"
+DEPEND="test? ( app-misc/geoclue )"
+
+S="${WORKDIR}"/${PN}
+
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+python_test() {
+ VIRTUALX_COMMAND="${PYTHON}"
+ cd "${BUILD_DIR}" || die
+ virtualmake "${S}"/tests/test.py
+}