summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-30 08:39:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-30 08:39:55 +0000
commitcd796afc475360001d3c970061746c7674c4cc30 (patch)
tree2861ab9fbedee62350b0bfac72460cf902ccb2ec /dev-python/python-distutils-extra
parentVersion bump. (diff)
downloadgentoo-2-cd796afc475360001d3c970061746c7674c4cc30.tar.gz
gentoo-2-cd796afc475360001d3c970061746c7674c4cc30.tar.bz2
gentoo-2-cd796afc475360001d3c970061746c7674c4cc30.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/ChangeLog8
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.36.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/python-distutils-extra/ChangeLog b/dev-python/python-distutils-extra/ChangeLog
index d77feb0aba9e..dd53dee0db4a 100644
--- a/dev-python/python-distutils-extra/ChangeLog
+++ b/dev-python/python-distutils-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-distutils-extra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.18 2012/10/12 00:54:58 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.19 2012/10/30 08:39:55 patrick Exp $
+
+*python-distutils-extra-2.36 (30 Oct 2012)
+
+ 30 Oct 2012; Patrick Lauer <patrick@gentoo.org>
+ +python-distutils-extra-2.36.ebuild:
+ Bump
12 Oct 2012; Mike Gilbert <floppym@gentoo.org>
python-distutils-extra-2.35.ebuild:
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.36.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.36.ebuild
new file mode 100644
index 000000000000..406b00753156
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.36.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.36.ebuild,v 1.1 2012/10/30 08:39:55 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+
+inherit distutils
+
+DESCRIPTION="You can integrate gettext support, themed icons and scrollkeeper based documentation in distutils."
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="doc/FAQ doc/README doc/setup.cfg.example doc/setup.py.example"
+PYTHON_MODNAME="DistUtilsExtra"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" \
+ -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" \
+ -e "s/test_requires_provides/_&/" \
+ -i test/auto.py
+}
+
+src_test() {
+ # 5 tests fail with disabled byte-compilation.
+ python_enable_pyc
+
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/auto.py
+ }
+ python_execute_function testing
+
+ python_disable_pyc
+}