summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-17 08:18:33 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-17 08:18:33 +0000
commitb9087ab7b93b0b48e0d934475053c429ca5ebc3e (patch)
tree8cfd3df09d671fb4c1e47de5c9535ad2e0a285ac /dev-python/python-distutils-extra
parentUse multilib_native_use* functions. (diff)
downloadgentoo-2-b9087ab7b93b0b48e0d934475053c429ca5ebc3e.tar.gz
gentoo-2-b9087ab7b93b0b48e0d934475053c429ca5ebc3e.tar.bz2
gentoo-2-b9087ab7b93b0b48e0d934475053c429ca5ebc3e.zip
bump; drop py2.6 pypy2_0 add py3.4 pypy support, tidy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/ChangeLog8
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/python-distutils-extra/ChangeLog b/dev-python/python-distutils-extra/ChangeLog
index 633ca4ac3037..dde9e974df82 100644
--- a/dev-python/python-distutils-extra/ChangeLog
+++ b/dev-python/python-distutils-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-distutils-extra
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.28 2014/03/31 20:40:58 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.29 2014/05/17 08:18:33 idella4 Exp $
+
+*python-distutils-extra-2.38 (17 May 2014)
+
+ 17 May 2014; Ian Delaney <idella4@gentoo.org>
+ +python-distutils-extra-2.38.ebuild:
+ bump; drop py2.6 pypy2_0 add py3.4 pypy support, tidy
31 Mar 2014; Michał Górny <mgorny@gentoo.org>
python-distutils-extra-2.33-r1.ebuild, python-distutils-extra-2.37-r1.ebuild:
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild
new file mode 100644
index 000000000000..c2baf5cb721e
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild,v 1.1 2014/05/17 08:18:33 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/{FAQ,README,setup.cfg.example,setup.py.example} )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" -e "s/test_requires_provides/_&/" \
+ -i test/auto.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # 5 tests fail with disabled byte-compilation (they rely on exact
+ # output from python).
+ local -x PYTHONDONTWRITEBYTECODE
+ "${PYTHON}" test/auto.py || die "Tests fail with ${EPYTHON}"
+}