summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-25 18:41:34 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-25 18:41:34 +0000
commit3fe47ca2ec2c05d1120ce020d23c01a5e49e8f47 (patch)
treeaefc174345f17046e4ac49b88f76bddd4e25ac63 /dev-python/python-cdb
parentMake it possible to compile splashutils without support for fbsplash (bug #14... (diff)
downloadgentoo-2-3fe47ca2ec2c05d1120ce020d23c01a5e49e8f47.tar.gz
gentoo-2-3fe47ca2ec2c05d1120ce020d23c01a5e49e8f47.tar.bz2
gentoo-2-3fe47ca2ec2c05d1120ce020d23c01a5e49e8f47.zip
Revision bump with a patch to build on python 2.5 and a src_test. Closes bug #148505.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-python/python-cdb')
-rw-r--r--dev-python/python-cdb/ChangeLog10
-rw-r--r--dev-python/python-cdb/files/digest-python-cdb-0.32-r13
-rw-r--r--dev-python/python-cdb/files/python-cdb-0.32-python-2.5-compat.patch22
-rw-r--r--dev-python/python-cdb/python-cdb-0.32-r1.ebuild36
4 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/python-cdb/ChangeLog b/dev-python/python-cdb/ChangeLog
index 22140a4820b0..e9754b55e193 100644
--- a/dev-python/python-cdb/ChangeLog
+++ b/dev-python/python-cdb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-cdb
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cdb/ChangeLog,v 1.13 2006/07/12 16:09:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cdb/ChangeLog,v 1.14 2006/09/25 18:41:34 marienz Exp $
+
+*python-cdb-0.32-r1 (25 Sep 2006)
+
+ 25 Sep 2006; Marien Zwart <marienz@gentoo.org>
+ +files/python-cdb-0.32-python-2.5-compat.patch,
+ +python-cdb-0.32-r1.ebuild:
+ Revision bump with a patch to build on python 2.5 and a src_test. Closes bug
+ #148505.
12 Jul 2006; Aron Griffis <agriffis@gentoo.org> python-cdb-0.32.ebuild:
Mark 0.32 stable on ia64
diff --git a/dev-python/python-cdb/files/digest-python-cdb-0.32-r1 b/dev-python/python-cdb/files/digest-python-cdb-0.32-r1
new file mode 100644
index 000000000000..e6948e4d208c
--- /dev/null
+++ b/dev-python/python-cdb/files/digest-python-cdb-0.32-r1
@@ -0,0 +1,3 @@
+MD5 0e303095f8c0ea9f09d7f11faf89805f python-cdb-0.32.tar.gz 18985
+RMD160 665102db0d08df00dde5bb235d708158fe15c2ce python-cdb-0.32.tar.gz 18985
+SHA256 24d2593b02faf036b1ae9fdad3af66d0013a8a2cb1669439ece4863b5d7756c6 python-cdb-0.32.tar.gz 18985
diff --git a/dev-python/python-cdb/files/python-cdb-0.32-python-2.5-compat.patch b/dev-python/python-cdb/files/python-cdb-0.32-python-2.5-compat.patch
new file mode 100644
index 000000000000..fe0210898c6f
--- /dev/null
+++ b/dev-python/python-cdb/files/python-cdb-0.32-python-2.5-compat.patch
@@ -0,0 +1,22 @@
+=== modified file 'src/cdbmodule.c'
+--- src/cdbmodule.c 2006-09-25 18:27:49 +0000
++++ src/cdbmodule.c 2006-09-25 18:28:34 +0000
+@@ -655,7 +655,7 @@
+
+ cdb_free(&self->c);
+
+- PyMem_DEL(self);
++ PyObject_DEL(self);
+ }
+
+ static PyObject *
+@@ -823,7 +823,7 @@
+ Py_DECREF(self->fntmp);
+ }
+
+- PyMem_DEL(self);
++ PyObject_DEL(self);
+ }
+
+ static PyObject *
+
diff --git a/dev-python/python-cdb/python-cdb-0.32-r1.ebuild b/dev-python/python-cdb/python-cdb-0.32-r1.ebuild
new file mode 100644
index 000000000000..8dce143027a9
--- /dev/null
+++ b/dev-python/python-cdb/python-cdb-0.32-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cdb/python-cdb-0.32-r1.ebuild,v 1.1 2006/09/25 18:41:34 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A Python extension module for cdb"
+SRC_URI="http://pilcrow.madison.wi.us/python-cdb/${P}.tar.gz"
+HOMEPAGE="http://pilcrow.madison.wi.us/#pycdb"
+
+SLOT="0"
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.2
+ dev-db/cdb"
+RDEPEND="${DEPEND}"
+
+DOCS="Example"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-python-2.5-compat.patch"
+}
+
+src_test() {
+ "${python}" setup.py install --home "${T}/test"
+ # This is not really intended as test but it is better than nothing.
+ PYTHONPATH="${T}/test/lib/python" "${python}" < Example || \
+ die "Test failed."
+ rm -rf "${T}/test"
+}