summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-11-30 03:50:52 +0000
committerMike Gilbert <floppym@gentoo.org>2013-11-30 03:50:52 +0000
commit892bc06738e71e9c4514cda6884895847aebcfed (patch)
treef632d6d055d431dccfd258740060f248099d6b5f /dev-python/pytest/pytest-2.4.2.ebuild
parentx86 stable wrt bug #488156 (diff)
downloadgentoo-2-892bc06738e71e9c4514cda6884895847aebcfed.tar.gz
gentoo-2-892bc06738e71e9c4514cda6884895847aebcfed.tar.bz2
gentoo-2-892bc06738e71e9c4514cda6884895847aebcfed.zip
Fix pexpect-3.0 problems in tests.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pytest/pytest-2.4.2.ebuild')
-rw-r--r--dev-python/pytest/pytest-2.4.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pytest/pytest-2.4.2.ebuild b/dev-python/pytest/pytest-2.4.2.ebuild
index 8100eeafa737..e65bd323ac96 100644
--- a/dev-python/pytest/pytest-2.4.2.ebuild
+++ b/dev-python/pytest/pytest-2.4.2.ebuild
@@ -1,16 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.3 2013/11/17 04:13:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.4 2013/11/30 03:50:52 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
inherit distutils-r1 eutils
-RESTRICT="test"
-#testing restricted due to test failures with pexpect-3.0 (which is required for pypy2_0 and python3_x support)
-#https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-
DESCRIPTION="py.test: simple powerful testing with Python"
HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -29,7 +25,11 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
test? ( dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}] )"
+ >=dev-python/pexpect-3.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/pytest-2.4.2-pexpect-3.0.patch"
+)
python_prepare_all() {
# Disable versioning of py.test script to avoid collision with