summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-28 05:20:38 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-28 05:20:38 +0000
commit91c1387c084492ccebfb263c056473b0a14a9a00 (patch)
tree767c795a459b6584cac3f992ec779f1b4851c458 /dev-python/pyserial/pyserial-2.7-r1.ebuild
parentamd64/arm/x86 stable wrt #506026 (diff)
downloadgentoo-2-91c1387c084492ccebfb263c056473b0a14a9a00.tar.gz
gentoo-2-91c1387c084492ccebfb263c056473b0a14a9a00.tar.bz2
gentoo-2-91c1387c084492ccebfb263c056473b0a14a9a00.zip
revbump; add IUSE doc, examples, dep for doc build and install, fixes Bug #497446 by C. Mayo
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyserial/pyserial-2.7-r1.ebuild')
-rw-r--r--dev-python/pyserial/pyserial-2.7-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyserial/pyserial-2.7-r1.ebuild b/dev-python/pyserial/pyserial-2.7-r1.ebuild
new file mode 100644
index 000000000000..af612578f97e
--- /dev/null
+++ b/dev-python/pyserial/pyserial-2.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyserial/pyserial-2.7-r1.ebuild,v 1.1 2014/03/28 05:20:38 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port Extension"
+HOMEPAGE="http://pyserial.sourceforge.net/ http://sourceforge.net/projects/pyserial/ http://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+PATCHES=( "${FILESDIR}"/mapping.patch )
+DOCS=( CHANGES.txt README.txt )
+
+python_prepare_all() {
+ # Usual avoid d'loading un-needed objects.inv file
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}