summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-07 01:46:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-07 01:46:30 +0000
commit519fd2eab13dc67589dc0ceecac713616769f5c1 (patch)
tree04c62b5c88611f96145f2081e37eb27512cf4f5d /dev-python/pyro
parentDelete older ebuild. (diff)
downloadgentoo-2-519fd2eab13dc67589dc0ceecac713616769f5c1.tar.gz
gentoo-2-519fd2eab13dc67589dc0ceecac713616769f5c1.tar.bz2
gentoo-2-519fd2eab13dc67589dc0ceecac713616769f5c1.zip
Version bump.
(Portage version: 14950-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog8
-rw-r--r--dev-python/pyro/pyro-3.10.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 472ebb939f19..db3697cb9782 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.22 2009/10/11 10:57:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.23 2009/12/07 01:46:30 arfrever Exp $
+
+*pyro-3.10 (07 Dec 2009)
+
+ 07 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyro-3.10.ebuild:
+ Version bump.
11 Oct 2009; Fabian Groffen <grobian@gentoo.org> pyro-3.9.1.ebuild:
Merge from Prefix
diff --git a/dev-python/pyro/pyro-3.10.ebuild b/dev-python/pyro/pyro-3.10.ebuild
new file mode 100644
index 000000000000..45539971d1c4
--- /dev/null
+++ b/dev-python/pyro/pyro-3.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.10.ebuild,v 1.1 2009/12/07 01:46:30 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="Pyro-${PV}"
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://pyro.sourceforge.net/ http://pypi.python.org/pypi/Pyro"
+SRC_URI="mirror://sourceforge/pyro/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyro"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}