summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-23 16:04:40 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-10-23 16:04:40 +0000
commite5ff0eeb3eb4a0092747b139edfb28b6ae2af509 (patch)
treed4cfc5d37f283b445bdcb3ff7ad170fc6d6b8983 /dev-python/pypax/pypax-0.3.0.ebuild
parentDrop alpha keywords (diff)
downloadgentoo-2-e5ff0eeb3eb4a0092747b139edfb28b6ae2af509.tar.gz
gentoo-2-e5ff0eeb3eb4a0092747b139edfb28b6ae2af509.tar.bz2
gentoo-2-e5ff0eeb3eb4a0092747b139edfb28b6ae2af509.zip
Version bump, adds XT_PAX support
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pypax/pypax-0.3.0.ebuild')
-rw-r--r--dev-python/pypax/pypax-0.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pypax/pypax-0.3.0.ebuild b/dev-python/pypax/pypax-0.3.0.ebuild
new file mode 100644
index 000000000000..7459c7246b0a
--- /dev/null
+++ b/dev-python/pypax/pypax-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.3.0.ebuild,v 1.1 2011/10/23 16:04:40 blueness Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+DESCRIPTION="Python module for reading or writing PaX flags to an ELF."
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+
+S="${WORKDIR}/elfix-${PV}/scripts"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/elfutils
+ >=sys-devel/binutils-2.14.90.0.8-r1"
+RDEPEND=""