summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-27 22:47:02 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-27 22:47:02 +0000
commitf0909990d8f40d257172045239e4edd672305b5a (patch)
tree02c44a1d72a6a2f32eb07be1afd15515379fc132 /dev-python/pyopencl
parentBump. (diff)
downloadgentoo-2-f0909990d8f40d257172045239e4edd672305b5a.tar.gz
gentoo-2-f0909990d8f40d257172045239e4edd672305b5a.tar.bz2
gentoo-2-f0909990d8f40d257172045239e4edd672305b5a.zip
Remove old.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/ChangeLog6
-rw-r--r--dev-python/pyopencl/pyopencl-2013.2-r1.ebuild47
-rw-r--r--dev-python/pyopencl/pyopencl-2013.2.ebuild65
3 files changed, 5 insertions, 113 deletions
diff --git a/dev-python/pyopencl/ChangeLog b/dev-python/pyopencl/ChangeLog
index 3e8b748d254e..6bb2edc13a50 100644
--- a/dev-python/pyopencl/ChangeLog
+++ b/dev-python/pyopencl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyopencl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.31 2015/03/08 23:56:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.32 2015/03/27 22:47:02 mrueg Exp $
+
+ 27 Mar 2015; Manuel Rüger <mrueg@gentoo.org> -pyopencl-2013.2-r1.ebuild,
+ -pyopencl-2013.2.ebuild:
+ Remove old.
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> pyopencl-2014.1.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild b/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild
deleted file mode 100644
index 17080712274d..000000000000
--- a/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2013.2-r1.ebuild,v 1.2 2014/04/04 01:38:52 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/pytools[${PYTHON_USEDEP}]
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-src_configure()
-{
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${PYTHON}" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- local EXAMPLES=( examples/. )
- einfo "Some of the examples provided by this package require dev-python/matplotlib."
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopencl/pyopencl-2013.2.ebuild b/dev-python/pyopencl/pyopencl-2013.2.ebuild
deleted file mode 100644
index 3f01d17e2866..000000000000
--- a/dev-python/pyopencl/pyopencl-2013.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2013.2.ebuild,v 1.1 2013/11/07 06:45:05 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python]
- dev-python/decorator
- dev-python/numpy
- dev-python/mako
- dev-python/pytools
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_configure()
-{
- configuration() {
- local myconf=()
-
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "$(PYTHON)" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install()
-{
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}