summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-23 03:05:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-23 03:05:26 +0000
commitc11f555ecac44c3b1c0bc9b3019580f23a293ed8 (patch)
tree2e8bfe4a3222a0f5944c2442891d08eb6af03171 /dev-python/pyme
parentunset the DISPLAY, bug #278524, thanks to Pinky (diff)
downloadgentoo-2-c11f555ecac44c3b1c0bc9b3019580f23a293ed8.tar.gz
gentoo-2-c11f555ecac44c3b1c0bc9b3019580f23a293ed8.tar.bz2
gentoo-2-c11f555ecac44c3b1c0bc9b3019580f23a293ed8.zip
Version bump (bug #278716). Fix building with app-crypt/gpgme >= 1.2.0 (bug #278720).
(Portage version: 13850-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyme')
-rw-r--r--dev-python/pyme/ChangeLog11
-rw-r--r--dev-python/pyme/pyme-0.8.1.ebuild54
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-python/pyme/ChangeLog b/dev-python/pyme/ChangeLog
index f1822fa6d60b..f5f86c07ec24 100644
--- a/dev-python/pyme/ChangeLog
+++ b/dev-python/pyme/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyme
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyme/ChangeLog,v 1.24 2009/01/25 15:13:04 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyme/ChangeLog,v 1.25 2009/07/23 03:05:26 arfrever Exp $
+
+*pyme-0.8.1 (23 Jul 2009)
+
+ 23 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyme-0.8.1.ebuild:
+ Version bump (bug #278716). Fix building with app-crypt/gpgme >= 1.2.0
+ (bug #278720).
25 Jan 2009; Markus Meier <maekke@gentoo.org> pyme-0.7.0-r1.ebuild:
add ~amd64, bug #255694
diff --git a/dev-python/pyme/pyme-0.8.1.ebuild b/dev-python/pyme/pyme-0.8.1.ebuild
new file mode 100644
index 000000000000..34d9f17b3008
--- /dev/null
+++ b/dev-python/pyme/pyme-0.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyme/pyme-0.8.1.ebuild,v 1.1 2009/07/23 03:05:26 arfrever Exp $
+
+EAPI="2"
+
+inherit distutils eutils
+
+DESCRIPTION="GPGME Interface for Python"
+HOMEPAGE="http://pyme.sourceforge.net"
+SRC_URI="mirror://sourceforge/pyme/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=app-crypt/gpgme-0.9.0"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -i \
+ -e 's:include/:include/gpgme/:' \
+ -e 's/SWIGOPT :=.*/& -D_FILE_OFFSET_BITS=64/' \
+ -e 's:$(PYTHON):/usr/bin/python:' \
+ -e '/-rm doc\/\*\.html$/d' \
+ Makefile || die "sed in Makefile failed"
+}
+
+src_compile() {
+ PYTHON="/usr/bin/python"
+ emake -j1 swig || die "emake swig failed"
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}
+
+#src_test() {
+# tests() {
+# PYTHONPATH=$(echo build-${PYTHON_ABI}/lib.*) "${python}" examples/genkey.py || die "genkey test failed"
+# }
+# python_execute_function tests
+#}