summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-06-26 01:38:28 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-06-26 01:38:28 +0000
commitf3b55a02c37f5b869b7ced71d0d01d910cb713af (patch)
tree95ce2b5115e35c526baa03e5a69086a3091b10ec /dev-python/pylint
parentRestore ~arm keyword dropped in last version bump, clean out test conditional... (diff)
downloadgentoo-2-f3b55a02c37f5b869b7ced71d0d01d910cb713af.tar.gz
gentoo-2-f3b55a02c37f5b869b7ced71d0d01d910cb713af.tar.bz2
gentoo-2-f3b55a02c37f5b869b7ced71d0d01d910cb713af.zip
Fix dependency regression from previous bump, restore ~arm keyword that was dropped in last bump
(Portage version: 2.1.12.9/cvs/Linux x86_64, signed Manifest commit with key 5C350883)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog6
-rw-r--r--dev-python/pylint/pylint-0.28.0.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 4df453664ee3..af279adab303 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.101 2013/06/25 03:11:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.102 2013/06/26 01:38:28 chutzpah Exp $
+
+ 26 Jun 2013; Patrick McLean <chutz@gentoo.org> pylint-0.28.0.ebuild:
+ Fix dependency regression from previous bump, restore ~arm keyword that was
+ dropped in last bump
25 Jun 2013; Mike Gilbert <floppym@gentoo.org> pylint-0.27.0-r1.ebuild,
pylint-0.28.0.ebuild:
diff --git a/dev-python/pylint/pylint-0.28.0.ebuild b/dev-python/pylint/pylint-0.28.0.ebuild
index ff64c63aeab9..d0dced3da169 100644
--- a/dev-python/pylint/pylint-0.28.0.ebuild
+++ b/dev-python/pylint/pylint-0.28.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.2 2013/06/25 03:11:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.3 2013/06/26 01:38:28 chutzpah Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2} )
-#PYTHON_REQ_USE="tk"
+
inherit distutils-r1
DESCRIPTION="Python code static checker"
@@ -17,13 +17,13 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-lin
IUSE="examples"
# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.19.0[${PYTHON_USEDEP}]
- >=dev-python/astng-0.16.1[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
+ >=dev-python/astng-0.24.3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
-DOCS=( doc/FAQ.txt doc/features.txt doc/manual.txt doc/quickstart.txt )
DISTUTILS_IN_SOURCE_BUILD=1
+DOCS=( doc/FAQ.txt doc/features.txt doc/manual.txt doc/quickstart.txt )
PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )