summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-22 20:29:42 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-22 20:29:42 +0000
commit707cc1489dadf51e62a2efebe68b278ea4713b71 (patch)
tree2424689249a124325ffd914aeafd100683cadb5a /dev-python/pyinotify
parentUpdate dependencies to efl-libs release 1.7.4 (diff)
downloadgentoo-2-707cc1489dadf51e62a2efebe68b278ea4713b71.tar.gz
gentoo-2-707cc1489dadf51e62a2efebe68b278ea4713b71.tar.bz2
gentoo-2-707cc1489dadf51e62a2efebe68b278ea4713b71.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyinotify')
-rw-r--r--dev-python/pyinotify/ChangeLog7
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/pyinotify/ChangeLog b/dev-python/pyinotify/ChangeLog
index 6678eb5e9a8a..a665c6054084 100644
--- a/dev-python/pyinotify/ChangeLog
+++ b/dev-python/pyinotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyinotify
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.48 2012/11/29 06:31:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.49 2012/12/22 20:29:42 mgorny Exp $
+
+*pyinotify-0.9.4-r1 (22 Dec 2012)
+
+ 22 Dec 2012; Michał Górny <mgorny@gentoo.org> +pyinotify-0.9.4-r1.ebuild:
+ Migrate to distutils-r1.
*pyinotify-0.9.4 (29 Nov 2012)
diff --git a/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..642e8ac8af1d
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild,v 1.1 2012/12/22 20:29:42 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy{1_8,1_9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="http://trac.dbzteam.org/pyinotify http://pypi.python.org/pypi/pyinotify"
+SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins python2/examples/* || die "Installation of examples failed"
+ fi
+}