summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-01-24 21:39:19 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-01-24 21:39:19 +0000
commite9af7608b21e68f968e8a3ac19c40d6a8e51781a (patch)
tree89deefc81ea31496dcdc04b9605657fa305c52c3 /dev-python/pyifp
parentStable on sparc wrt #114587 (diff)
downloadgentoo-2-e9af7608b21e68f968e8a3ac19c40d6a8e51781a.tar.gz
gentoo-2-e9af7608b21e68f968e8a3ac19c40d6a8e51781a.tar.bz2
gentoo-2-e9af7608b21e68f968e8a3ac19c40d6a8e51781a.zip
New package, python bindings for media-libs/libifp
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-python/pyifp')
-rw-r--r--dev-python/pyifp/ChangeLog10
-rw-r--r--dev-python/pyifp/Manifest5
-rw-r--r--dev-python/pyifp/files/digest-pyifp-0.2.21
-rw-r--r--dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch11
-rw-r--r--dev-python/pyifp/metadata.xml12
-rw-r--r--dev-python/pyifp/pyifp-0.2.2.ebuild27
6 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pyifp/ChangeLog b/dev-python/pyifp/ChangeLog
new file mode 100644
index 000000000000..30df48260645
--- /dev/null
+++ b/dev-python/pyifp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pyifp
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyifp/ChangeLog,v 1.1 2006/01/24 21:39:19 chutzpah Exp $
+
+*pyifp-0.2.2 (24 Jan 2006)
+
+ 24 Jan 2006; Patrick McLean <chutzpah@gentoo.org>
+ +files/pyifp-0.2.2-setup-fix.patch, +metadata.xml, +pyifp-0.2.2.ebuild:
+ Initial version.
+
diff --git a/dev-python/pyifp/Manifest b/dev-python/pyifp/Manifest
new file mode 100644
index 000000000000..ecf50f185660
--- /dev/null
+++ b/dev-python/pyifp/Manifest
@@ -0,0 +1,5 @@
+MD5 d802eb71553d15e7200aa94a2f1706ec ChangeLog 291
+MD5 73717b29fb8212c72f0a92c3cf09caec files/digest-pyifp-0.2.2 62
+MD5 3a7bcffe90a16587f5f8b37882be9927 files/pyifp-0.2.2-setup-fix.patch 513
+MD5 46d88885d15eac3e003d365403e92602 metadata.xml 370
+MD5 409b46498880d406752f29baf609017d pyifp-0.2.2.ebuild 568
diff --git a/dev-python/pyifp/files/digest-pyifp-0.2.2 b/dev-python/pyifp/files/digest-pyifp-0.2.2
new file mode 100644
index 000000000000..c4186c5228eb
--- /dev/null
+++ b/dev-python/pyifp/files/digest-pyifp-0.2.2
@@ -0,0 +1 @@
+MD5 32afb70684d45215f4c91fc498d8d338 pyifp-0.2.2.tar.gz 21378
diff --git a/dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch b/dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch
new file mode 100644
index 000000000000..2582e0fd8841
--- /dev/null
+++ b/dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch
@@ -0,0 +1,11 @@
+--- pyifp-0.2.2/setup.py 2005-02-21 01:36:05.000000000 -0500
++++ pyifp-0.2.2-fixed/setup.py 2005-10-15 13:29:26.000000000 -0400
+@@ -54,7 +54,7 @@
+ self.swig_inc = 'SWIG'
+ self.swig_shadow = None
+
+- def swig_sources(self, sources):
++ def swig_sources(self, sources, extension=None):
+ """Override the definition of 'swig_sources' in build_ext. This
+ is essentially the same function but with better swig support.
+ I will now quote the original docstring:
diff --git a/dev-python/pyifp/metadata.xml b/dev-python/pyifp/metadata.xml
new file mode 100644
index 000000000000..f704eaef64dc
--- /dev/null
+++ b/dev-python/pyifp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+</maintainer>
+<longdescription lang="en">
+Python bindings for libifp library for accessing iRiver iFP devices.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyifp/pyifp-0.2.2.ebuild b/dev-python/pyifp/pyifp-0.2.2.ebuild
new file mode 100644
index 000000000000..ebcc3cd73250
--- /dev/null
+++ b/dev-python/pyifp/pyifp-0.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyifp/pyifp-0.2.2.ebuild,v 1.1 2006/01/24 21:39:19 chutzpah Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Python bindings for libifp library for accessing iRiver iFP devices"
+HOMEPAGE="http://ifp-gnome.sourceforge.net"
+SRC_URI="mirror://sourceforge/ifp-gnome/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+LICENSE="LGPL-2"
+SLOT="0"
+
+DEPEND="dev-lang/python
+ >=media-libs/libifp-1.0.0.2"
+
+DOCS="AUTHORS COPYING ChangeLog NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-setup-fix.patch
+}