summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-05-25 21:19:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-05-25 21:19:59 +0000
commit17139fa488616c6ba44d11831278a3e81bda00b0 (patch)
tree10a43b6c8df0e7169eed901807f52e871d166656 /dev-python/pygobject
parentAdd libffi use flag for dev-python/pygobject (diff)
downloadgentoo-2-17139fa488616c6ba44d11831278a3e81bda00b0.tar.gz
gentoo-2-17139fa488616c6ba44d11831278a3e81bda00b0.tar.bz2
gentoo-2-17139fa488616c6ba44d11831278a3e81bda00b0.zip
bump to 2.14.2. Fix bug #198875. fix QA on 2.12.3, changing to ~mips, mips is experimental.
(Portage version: 2.1.5)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog12
-rw-r--r--dev-python/pygobject/pygobject-2.12.3.ebuild14
-rw-r--r--dev-python/pygobject/pygobject-2.14.2.ebuild75
3 files changed, 93 insertions, 8 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 4f877cc81d68..cb76ae1d4fc9 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.37 2008/03/22 03:49:36 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.38 2008/05/25 21:19:59 eva Exp $
+
+ 25 May 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ pygobject-2.12.3.ebuild:
+ fix QA on 2.12.3, changing to ~mips, mips is experimental.
+
+*pygobject-2.14.2 (25 May 2008)
+
+ 25 May 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +pygobject-2.14.2.ebuild:
+ bump to 2.14.2. Fix bug #198875.
22 Mar 2008; Daniel Gryniewicz <dang@gentoo.org> pygobject-2.14.1.ebuild:
Marked stable on amd64 for bug #212986
diff --git a/dev-python/pygobject/pygobject-2.12.3.ebuild b/dev-python/pygobject/pygobject-2.12.3.ebuild
index 01542281c1f1..1fa8ae282adf 100644
--- a/dev-python/pygobject/pygobject-2.12.3.ebuild
+++ b/dev-python/pygobject/pygobject-2.12.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.12.3.ebuild,v 1.16 2007/07/26 21:32:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.12.3.ebuild,v 1.17 2008/05/25 21:19:59 eva Exp $
WANT_AUTOCONF=latest
WANT_AUTOMAKE=1.8
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.pygtk.org/"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="doc"
RDEPEND=">=dev-lang/python-2.3.5
@@ -48,10 +48,10 @@ src_install() {
doins -r examples
python_version
- mv ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
- ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
- mv ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
- ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
}
pkg_postinst() {
diff --git a/dev-python/pygobject/pygobject-2.14.2.ebuild b/dev-python/pygobject/pygobject-2.14.2.ebuild
new file mode 100644
index 000000000000..2ede2d5f45da
--- /dev/null
+++ b/dev-python/pygobject/pygobject-2.14.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.1 2008/05/25 21:19:59 eva Exp $
+
+inherit gnome2 python autotools
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples libffi"
+
+# glib higher dep than in configure.in comes from a runtime version check and ensures that
+# timeout_add_seconds is available for any packages that depend on pygobject and use it
+# python high dep for a fixed python-config, as aclocal.m4/configure in the tarball requires it to function properly
+RDEPEND=">=dev-lang/python-2.4.4-r5
+ >=dev-libs/glib-2.13.5
+ !<dev-python/pygtk-2.9"
+DEPEND="${RDEPEND}
+ doc? ( dev-libs/libxslt >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if use libffi && ! built_with_use sys-devel/gcc libffi; then
+ eerror "libffi support not found in sys-devel/gcc." && die
+ fi
+
+ G2CONF="${G2CONF} $(use_enable doc docs) $(use_with libffi ffi)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
+ # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
+ # patches (for tmpfs amongst other things). Upstreams hit by this should
+ # move to newer automake versions ideally.
+ AT_M4DIR="m4" eautomake
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+
+ python_version
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py-2.0
+ mv "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth \
+ "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth-2.0
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym /usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.pth pygtk.pth-[0-9].[0-9]
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/pygtk.py
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}