summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-09 17:13:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-09 17:13:30 +0000
commit991986cc7250ca09ec08fea6e2d3a3763b16032b (patch)
tree1748847b786452af4690f239632de2c068e58833 /dev-python/pyfltk
parent0.8.30 version bump and remove old. (diff)
downloadgentoo-2-991986cc7250ca09ec08fea6e2d3a3763b16032b.tar.gz
gentoo-2-991986cc7250ca09ec08fea6e2d3a3763b16032b.tar.bz2
gentoo-2-991986cc7250ca09ec08fea6e2d3a3763b16032b.zip
Version bump. Fix detection of Linux version 3.x in both 1.1.5 and 1.3.0. Bugs 359347 and 375253.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyfltk')
-rw-r--r--dev-python/pyfltk/ChangeLog9
-rw-r--r--dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch15
-rw-r--r--dev-python/pyfltk/pyfltk-1.1.5.ebuild8
-rw-r--r--dev-python/pyfltk/pyfltk-1.3.0.ebuild45
4 files changed, 73 insertions, 4 deletions
diff --git a/dev-python/pyfltk/ChangeLog b/dev-python/pyfltk/ChangeLog
index 5e8b194e117f..b4ba179ae04d 100644
--- a/dev-python/pyfltk/ChangeLog
+++ b/dev-python/pyfltk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyfltk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/ChangeLog,v 1.27 2011/05/05 15:17:41 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/ChangeLog,v 1.28 2011/12/09 17:13:29 ssuominen Exp $
+
+*pyfltk-1.3.0 (09 Dec 2011)
+
+ 09 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> pyfltk-1.1.5.ebuild,
+ +pyfltk-1.3.0.ebuild, +files/pyfltk-1.3.0-linux-3.x-detection.patch:
+ Version bump. Fix detection of Linux version 3.x in both 1.1.5 and 1.3.0.
+ Bugs 359347 and 375253.
05 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pyfltk-1.1.5.ebuild, +files/pyfltk-1.1.5-swig-2.patch:
diff --git a/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
new file mode 100644
index 000000000000..9b084616c871
--- /dev/null
+++ b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/show_bug.cgi?id=375253
+
+http://lipyrary.blogspot.com/2011/09/python-and-linux-kernel-30-sysplatform.html
+
+--- setup.py
++++ setup.py
+@@ -76,7 +76,7 @@
+ lib_dir_list = [fltk_lib_dir]
+ lib_list = ["fltk", "kernel32", "user32", "gdi32", "winspool", "comdlg32", "Comctl32", "advapi32", "shell32", "oleaut32", "odbc32", "odbccp32", "stdc++", "msvcr71"]
+ #link_arg_list=["-Wl,--enable-runtime-pseudo-reloc", "-Wl,--enable-auto-import"]
+-elif sys.platform == 'linux2':
++elif sys.platform.startswith('linux'):
+ print "Building for Linux"
+ # ugly hack to force distutils to use g++ instead of gcc for linking
+ from distutils import sysconfig
diff --git a/dev-python/pyfltk/pyfltk-1.1.5.ebuild b/dev-python/pyfltk/pyfltk-1.1.5.ebuild
index f7c353303e47..81a1a14f688e 100644
--- a/dev-python/pyfltk/pyfltk-1.1.5.ebuild
+++ b/dev-python/pyfltk/pyfltk-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.5.ebuild,v 1.10 2011/05/05 15:17:41 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.5.ebuild,v 1.11 2011/12/09 17:13:29 ssuominen Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -21,7 +21,7 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="doc"
-RDEPEND="x11-libs/fltk:1[opengl]"
+RDEPEND="<x11-libs/fltk-1.3.0:1[opengl]"
DEPEND="${RDEPEND}
>=dev-lang/swig-1.3.38"
@@ -37,7 +37,9 @@ src_prepare() {
# move docs because the swig stuff will remove them
use doc && cp -r fltk fltk.docs
- epatch "${FILESDIR}/${P}-swig-2.patch"
+ epatch \
+ "${FILESDIR}"/${P}-swig-2.patch \
+ "${FILESDIR}"/${PN}-1.3.0-linux-3.x-detection.patch
}
src_compile() {
diff --git a/dev-python/pyfltk/pyfltk-1.3.0.ebuild b/dev-python/pyfltk/pyfltk-1.3.0.ebuild
new file mode 100644
index 000000000000..895d6d005716
--- /dev/null
+++ b/dev-python/pyfltk/pyfltk-1.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.3.0.ebuild,v 1.1 2011/12/09 17:13:29 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+MY_P=pyFltk-${PV}
+
+DESCRIPTION="Python interface to Fltk library"
+HOMEPAGE="http://pyfltk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/fltk-1.3.0:1[opengl]"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-2.0.4"
+
+PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing")
+PYTHON_MODNAME="fltk"
+DOCS="CHANGES README TODO"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linux-3.x-detection.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ # FIXME: Install documentation ourself. Would some argument to distutils_src_install
+ # instead help?
+ rm -rf "${ED}"/usr/lib*/python*/site-packages/fltk/docs
+ dohtml fltk/docs/*
+}