summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-11 16:05:33 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-11 16:05:33 +0000
commitc260972413c9783b27ad15ee99b78c6473f4c39b (patch)
tree147a7d187bdcb1abcf38eda08a859c56bf9b370e /dev-python/pyface
parentrevbump to fix bug 465470, drop deprecated beta3 (diff)
downloadgentoo-2-c260972413c9783b27ad15ee99b78c6473f4c39b.tar.gz
gentoo-2-c260972413c9783b27ad15ee99b78c6473f4c39b.tar.bz2
gentoo-2-c260972413c9783b27ad15ee99b78c6473f4c39b.zip
migration to distutils-r1, rm py2.6 support, fixed test phase
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyface')
-rw-r--r--dev-python/pyface/ChangeLog7
-rw-r--r--dev-python/pyface/pyface-4.3.0-r1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/pyface/ChangeLog b/dev-python/pyface/ChangeLog
index dec1b671c2ba..b7bb90218531 100644
--- a/dev-python/pyface/ChangeLog
+++ b/dev-python/pyface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyface
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.7 2013/04/03 07:04:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.8 2013/04/11 16:05:33 idella4 Exp $
+
+*pyface-4.3.0-r1 (11 Apr 2013)
+
+ 11 Apr 2013; Ian Delaney <idella4@gentoo.org> +pyface-4.3.0-r1.ebuild:
+ migration to distutils-r1, rm py2.6 support, fixed test phase
*pyface-4.3.0 (03 Apr 2013)
diff --git a/dev-python/pyface/pyface-4.3.0-r1.ebuild b/dev-python/pyface/pyface-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..ad77928c486f
--- /dev/null
+++ b/dev-python/pyface/pyface-4.3.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/pyface-4.3.0-r1.ebuild,v 1.1 2013/04/11 16:05:33 idella4 Exp $
+
+EAPI=5
+
+# https://github.com/enthought/pyface/issues/40 confirms only py2.7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface http://pypi.python.org/pypi/pyface"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ || ( dev-python/wxpython dev-python/PyQt4 dev-python/pyside )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS=( docs/*.txt )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyqt
+ # set nosetests to ignore tests unpassable by these vars.
+ VIRTUALX_COMMAND="nosetests -v -I composite_grid_model_test_case* \
+ -I simple_grid_model_test_case* \
+ -I test_split_editor_area_pane*" virtualmake
+}
+
+python_install_all() {
+ find -name "*LICENSE*.txt" -delete
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}