summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 15:36:30 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2013-06-08 15:36:30 +0000
commit716bfcd9ccb74346a7fffaa1f92a2fcb82ea879d (patch)
tree9a6321e4daae4d023fc724876aa53d0f69b38e3c /dev-python/pyechonest
parentFix PIL import for Pillow compat. Revert imaging dep change in ebuild which d... (diff)
downloadgentoo-2-716bfcd9ccb74346a7fffaa1f92a2fcb82ea879d.tar.gz
gentoo-2-716bfcd9ccb74346a7fffaa1f92a2fcb82ea879d.tar.bz2
gentoo-2-716bfcd9ccb74346a7fffaa1f92a2fcb82ea879d.zip
Version bump, update to EAPI5, add doc USE flag for API documentation
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 7B087241)
Diffstat (limited to 'dev-python/pyechonest')
-rw-r--r--dev-python/pyechonest/ChangeLog8
-rw-r--r--dev-python/pyechonest/pyechonest-7.2.1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pyechonest/ChangeLog b/dev-python/pyechonest/ChangeLog
index fb502ade2c65..96c8bde454aa 100644
--- a/dev-python/pyechonest/ChangeLog
+++ b/dev-python/pyechonest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyechonest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyechonest/ChangeLog,v 1.1 2013/01/02 23:16:27 sochotnicky Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyechonest/ChangeLog,v 1.2 2013/06/08 15:36:30 sochotnicky Exp $
+
+*pyechonest-7.2.1 (08 Jun 2013)
+
+ 08 Jun 2013; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ +pyechonest-7.2.1.ebuild:
+ Version bump, update to EAPI5, add doc USE flag for API documentation
*pyechonest-7.1.0 (02 Jan 2013)
diff --git a/dev-python/pyechonest/pyechonest-7.2.1.ebuild b/dev-python/pyechonest/pyechonest-7.2.1.ebuild
new file mode 100644
index 000000000000..47e5f141b273
--- /dev/null
+++ b/dev-python/pyechonest/pyechonest-7.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyechonest/pyechonest-7.2.1.ebuild,v 1.1 2013/06/08 15:36:30 sochotnicky Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to The Echo Nest APIs"
+HOMEPAGE="http://echonest.github.com/pyechonest/"
+SRC_URI="https://github.com/echonest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG README.md )
+
+use examples && DOCS+=( examples/ )
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation by" ${PYTHON}
+ PYTHONPATH=".." emake -C doc html || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ use doc && dohtml -r doc/build/html/
+}