summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-11-17 23:19:54 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-11-17 23:19:54 +0000
commit20fb528d4f4ca41e2b66ba342ec527fc4f8e8dfc (patch)
treebc94665e9c365b7b4f843c56d2489118bd77483c /dev-python/pycdio
parentAdd trailing slant to HOMEPAGE. (diff)
downloadgentoo-2-20fb528d4f4ca41e2b66ba342ec527fc4f8e8dfc.tar.gz
gentoo-2-20fb528d4f4ca41e2b66ba342ec527fc4f8e8dfc.tar.bz2
gentoo-2-20fb528d4f4ca41e2b66ba342ec527fc4f8e8dfc.zip
version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/ChangeLog7
-rw-r--r--dev-python/pycdio/files/digest-pycdio-0.133
-rw-r--r--dev-python/pycdio/pycdio-0.13.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/pycdio/ChangeLog b/dev-python/pycdio/ChangeLog
index 62b416a57f33..b516bd107257 100644
--- a/dev-python/pycdio/ChangeLog
+++ b/dev-python/pycdio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycdio
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/ChangeLog,v 1.1 2007/05/16 22:09:01 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/ChangeLog,v 1.2 2007/11/17 23:19:53 sbriesen Exp $
+
+*pycdio-0.13 (17 Nov 2007)
+
+ 17 Nov 2007; Stefan Briesenick <sbriesen@gentoo.org> +pycdio-0.13.ebuild:
+ version bump.
*pycdio-0.12 (16 May 2007)
diff --git a/dev-python/pycdio/files/digest-pycdio-0.13 b/dev-python/pycdio/files/digest-pycdio-0.13
new file mode 100644
index 000000000000..5fb5e003bf0b
--- /dev/null
+++ b/dev-python/pycdio/files/digest-pycdio-0.13
@@ -0,0 +1,3 @@
+MD5 dc54be352c00457e8c040cd19a434cf0 pycdio-0.13.tar.gz 343914
+RMD160 6dab76a5811659272d54ac56df3c488912956960 pycdio-0.13.tar.gz 343914
+SHA256 0ff911a5a7d1ee5eb4da6227332e246fcd5bb4af9e041fc33a9b911458efbe68 pycdio-0.13.tar.gz 343914
diff --git a/dev-python/pycdio/pycdio-0.13.ebuild b/dev-python/pycdio/pycdio-0.13.ebuild
new file mode 100644
index 000000000000..705b94bbd75a
--- /dev/null
+++ b/dev-python/pycdio/pycdio-0.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycdio/pycdio-0.13.ebuild,v 1.1 2007/11/17 23:19:53 sbriesen Exp $
+
+inherit eutils distutils flag-o-matic multilib
+
+DESCRIPTION="pycdio is a Python interface to the CD Input and Control library (libcdio)"
+HOMEPAGE="http://savannah.gnu.org/projects/libcdio/"
+SRC_URI="http://ftp.gnu.org/gnu/libcdio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ dev-libs/libcdio
+ dev-lang/swig"
+
+PYTHON_MODNAME=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # remove obsolete sys.path and adjust 'data' path in examples
+ sed -i -e "s:^sys.path.insert.*::" -e "s:\.\./data:./data:g" example/*.py.in
+}
+
+src_compile() {
+ # -fPIC is needed for shared objects on some platforms (amd64 and others)
+ append-flags -fPIC
+
+ distutils_src_compile
+}
+
+src_install(){
+ make DESTDIR="${D}" install || die "make install failed."
+ chmod a+x "${D}"usr/$(get_libdir)/python*/site-packages/*.so
+ rm -f "${D}"usr/$(get_libdir)/python*/site-packages/*.py[co]
+
+ dodoc AUTHORS NEWS README
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example/{README,*.py}
+ doins -r data
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ for pymod in cdio pycdio iso9660 pyiso9660; do
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}.py
+ done
+}